Algoritmia ejercicio

Solo disponible en BuenasTareas
  • Páginas : 5 (1062 palabras )
  • Descarga(s) : 0
  • Publicado : 30 de agosto de 2012
Leer documento completo
Vista previa del texto
Por razones de estadística el directorio de una empresa solicita un proceso que imprima cuantos de sus empleados ganan hasta 500.000, cuantos ganan más de 500.000 y hasta 800.000, cuánto ganan más de 800.000 y hasta 1.000.000 y cuantos ganan más de 1.000.000, por cada empleado se debe ingresar los siguientes datos.
Código del empleado (Enter para fin)
E ingresar tambiénsueldos.

Entorno
VNombre es alfanumérico
VSueldo es numérico
VCont1 es numérico
VCont2 es numérico
VCont3 es numérico
VCont4 es numérico


Cuerpo principal
Inicio
Ingresar “Nombre del empleado”, VNombre
Mientras VNombre <> “ “
Ingresar“Sueldo”, VSueldo
Si VSueldo <= 500.000
VCont1 = VCont1 + 1
Fin Si
Si VSueldo > 500.000 y <= 800.000
VCont2 = VCont2 + 1
Fin Si
Si VSueldo > 800.000 y <= 1.000.000
VCont3 = VCont3 + 1
Fin Si
Si VSueldo > 1.000.000
VCont4 = VCont4 +1
Fin SI
Fin Mientras
Imprimir “Empleados ganan hasta 500.000”, VCont1
Imprimir “Empleados ganan más de 500.000 hasta 800.000”, VCont2
Imprimir “Empleados ganan más de 800.000 hasta 1.000.000”, VCont3
Imprimir “Empleados ganan más de 1.000.000”, VCont4
FinHacer un proceso que permita ingresar tres números. Si se cumple que el primero es divisible por tres, el segundo es divisible por cinco y el tercero es divisible por dos; sumar los tres valores y dividir el resultado por cuatro. Si no se cumplen las condiciones sumar los dos primeros y el resultado multiplicar por el tercero. Imprimir el resultado obtenido. Repetir el proceso 100 veces.Entorno
VNum1 es numérico
VNum2 es numérico
VNum3 es numérico
Resultado es numérico

Cuerpo principal
Inicio
Resultado = 0;
Ingresar “El primer número “, VNum1
Ingresar “El segundo número “, VNum2
Ingresar “El tercer número “, VNum3
Desde 1 hasta 100
Si(VNum1 / 3 mod=0) Y (VNum2/5 mod=0) Y (VNum3/2 mod=0)
Resultado = (VNum1 + VNum2 + VNum3) / 4
Sino
Resultado = (VNum1 + VNum2) x VNum3
Fin Si
Imprimir “El resultado es “, Resultado
Fin Desde
Fin

Hacer un proceso que permita ingresar.
Nombre del cliente (enter para fin)
Clave de calculoMonto base
Imprimir el saldo de cada cliente, el cual se halla según su clave
Si clave igual a 1, saldo es igual a 0,92 por monto base.
Si clave igual a 2, saldo es igual a 0,94 por monto base.
Si clave igual a 3, saldo es igual a 0,96 por monto base.
Para cada cliente imprimir Nombre, Clave y Saldo. Imprimir también la cantidad de clientespor cada clave y la suma total de saldos por cada clave.


Entorno
VNombre es alfanumérico
VClave es numérico
VMonto es numérico
VSaldo es numérico
VContClave1 es numérico
VContClave2 es numérico
VContClave3 es numérico
VSuma1 es numérico
VSuma2 es numérico
VSuma3 esnumérico

Cuerpo principal
Inicio
VSaldo = 0
VContClave1 = 0
VContClave2 = 0
VContClave3 = 0
VSuma1 = 0
VSuma2 = 0
VSuma3 = 0

Ingresar “Nombre del cliente”, VNombre
Mientras VNombre <> “ “
Ingresar “Clave Calculo”, VClave
Ingresar...
tracking img