Algoritmo cafeteria

Solo disponible en BuenasTareas
  • Páginas : 2 (393 palabras )
  • Descarga(s) : 0
  • Publicado : 30 de marzo de 2011
Leer documento completo
Vista previa del texto
* Hacer un programa que permita administrar las ventas de un día en una cafetería.
* El programa debe permitir :
* Manejo de menús de acuerdo al turno (matutino, vespertino)
*Conteo de platillo vendido
* Calculo de cambio al usuario
* Manejo de inventario de platillos
* Salir cuando el usuario lo decida

Análisis :
1. Manejo de turno
2. Manejo demenú de acuerdo a turno
3. De acuerdo a la opción solicitada establecer precio y determinar cambio
4. Inventario de platillos y
5. Conteo de platillos vendidos
6. Todo lo debe hacermientras el usuario lo solicite

Algoritmo:cafetería
Variables: Entero salir = 2, Papas = 6, Fruta = 1'0, Huevo= 5, Mole = 5, Tacos = 7, Enchiladas = 10, opcion
Char turno
Flotante cambio, pagoInicio
Mientras(salir ==2)
{
Escribir(“turno: m:matutino v:vespertino”)
Leer(turno)
Si(turno = ‘m’)
Escribir(“seleeciona una opción: 1:papas 2: fruta 3:huevo”)
Leer(opción)Según_sea(opcion)
Caso 1:
Si(papas >0)
Escribir(Precio de las papas: 20. con cuanto pagas?
) leer(pago)
Cambio= pago -20
Papas- -
Inventario++
Escribir(tu cambioes de: cambio)
Sino
Escribir(No hay platillo disponible)
Fin_si
Caso2:
Si(fruta >0)
Escribir(Precio de las fruta: 15. con cuanto pagas?
) leer(pago)
Cambio=pago -15
fruta- -
Inventario++
Escribir(tu cambio es de: cambio)
Sino
Escribir(No hay platillo disponible)
Fin_si

Caso 3:
Si(huevo >0)
Escribir(Precio delas huevo: 25. con cuanto pagas?
) leer(pago)
Cambio= pago -25
huevo- -
Inventario++
Escribir(tu cambio es de: cambio)
Sino
Escribir(No hay platillo disponible)Fin_si

Default:
Escribir(“Opcion no válida”)
Fin_segun_Sea
Sino
Escribir(“seleeciona una opción: 1:mole 2: tacos 3:enchiladas”)
Leer(opción)
Según_sea(opcion)...
tracking img