Algoritmos en psint

Solo disponible en BuenasTareas
  • Páginas : 13 (3107 palabras )
  • Descarga(s) : 0
  • Publicado : 9 de junio de 2011
Leer documento completo
Vista previa del texto
NÚMERO 01

Proceso SIN_TITULO
Escribir "valor de a";
Leer a;
Escribir "valor de b";
Leer b;
Escribir "valor de c";
Leer c;
p<-(a+b+c)/2
A<-RC(p*(p-a)*(p-b)*(p-c))
Escribir "el area es igual",a
FinProceso

NÚMERO 02

Proceso sin_titulo
Escribir "ingrese cantidad de desaprobados";
Leer desaprobados;
Escribir "ingrese cantidad de aprobados";
Leer aprobados;Escribir "ingrese cantidad de notables";
Leer notables;
Escribir "ingrese cantidad de sobresalientes";
Leer sobresalientes;
total<-(aprobados+desaprobados+notables+sobresalientes);
PSA<-(aprobados+notables+sobresalientes)/total*100
PSD<-desaprobados/total*100
PSN<-notables/total*100
PSS<-sobresalientes/total*100
FinProceso

NÚMERO 03

Proceso sueldo_mensual_anualsueldo_semanal<-200
Escribir "Sueldo semanal =",sueldo_semanal
sueldo_mensual<-200*4
Escribir "Sueldo mensual =",sueldo_mensual
sueldo_anual<-200*48
Escribir "Sueldo anual =",sueldo_anual
FinProceso

NÚMERO 04

Proceso Porcentaje_alumnos
Escribir "cantidad de varones";
Leer X;
Escribir "cantidad de mujeres";
Leer Z;
total<-X+Z
Escribir "total de alumnos=",total
PSV<-X/total*100
Escribir "porcentaje de varones =",PSV
PSM<-Z/total*100
Escribir "porcenraje de mujeres =",PSM
FinProceso

NÚMERO 05

Proceso Suma_dos_numeros
Escribir "Ingresar primer numero" ;
Leer A;
Escribir "Ingresar segundo numero";
Leer B;
total<-A+B
Escribir "La suma de los numeros =",total
FinProceso

NÚMERO 06

Proceso area_trianguloEscribir "ingrese el valor de la base";
Leer A;
Escribir "ingrese el valor de la altura";
Leer H;
area<-A*H/2
Escribir "area del triangulo =",area
FinProceso

NÚMERO 07

Proceso departamento_climatologia
Escribir "Ingrese la temperatura en grados celsius";
Leer X;
F<-9/5*(X+32)
Escribir "Equivalente en grados Fahrenheit =",F
Escribir "Ingrese la cantidad de agua enpulgadas";
Leer Z;
M<-25.5*Z
Escribir "Equivalente en milimetros",M
FinProceso

NÚMERO 08

Proceso sin_titulo
Escribir "Inngrese su fecha de Nacimiento";
Leer X;
Si X>1870 Entonces
edad_actual<-2010-X
Escribir "Su edad actual es =",edad_actual
Sino
Escribir "Accion invalida es imposible que tenga esa edad";
FinSi
FinProceso

NÚMERO 09

Proceso sin_tituloTDS<-0.07
TDAFP<-0.1225

Escribir "Ingrese horas de trabajo:";
Leer HorTrab;
Escribir "Ingrese pago por hora:";
Leer PagoHora;
SBruto<-HorTrab*PagoHora
DesSalud<-SBruto*TDS
DesAFp<-SBruto*TDAFP
Desc<-DesSalud+DesAFP
RemLiq<-SBruto-Desc
Escribir "El descuento total = S/",Desc
Escribir "La remuneraacion liquida = S/",RemLiq
FinProceso

NÚMERO 10Proceso sin_titulo
Escribir "Ingrese A:";
Leer A;
Escribir "Ingrese B:";
Leer B;
Aux<-A
A<-B
B<-Aux
Escribir "A =",A
Escribir "B =",B
FinProceso

NÚMERO 11

Proceso sin_titulo

Escribir "Ingrese el tipo de cambio";
Leer A;
Escribir "Ingrese el monto en soles";
Leer B;
CD<-B/A
Escribir "El monto en dolares es =",CD
FinProceso

NÚMERO 12

Procesosin_titulo
Escribir "Ingrese su nombre";
Leer Nombre;
Escribir "Ingrese su edad";
Leer Edad
Si Edad >= 18 Entonces
Escribir Nombre,"Mayor de edad";
Sino
Escribir Nombre,"Menor de edad";
FinSi
FinProceso

NÚMERO 13

Proceso sin_titulo
Escribir "Ingrese su nombre";
Leer Nombre;
Escribir "Ingrese su nota";
Leer Nota;
Si Nota >= 11 Entonces
Escribir Nombre,"Esta aprobado(a)";
Sino
Escribir Nombre, "Esta dasaprobado(a)";
FinSi
FinProceso

NÚMERO 14

Proceso sin_titulo
Escribir "Nombre del vendedor";
Leer Vendedor;
Escribir "Ingrese el valor de la venta";
Leer Venta;
Si Venta < 5000 Entonces
comision1<-0.10 * Venta
Escribir Vendedor, "Su comision = S/",comision1
Sino
comision2<-0.12 * Venta
Escribir...
tracking img