Algoritmos

Solo disponible en BuenasTareas
  • Páginas : 5 (1097 palabras )
  • Descarga(s) : 4
  • Publicado : 21 de febrero de 2010
Leer documento completo
Vista previa del texto
EJERCICIO Nº 1
1.- Un profesor necesita un algoritmo para calcular el promedio de notas que obtuvieron sus alumnos en una prueba. Prepare dos soluciones: (a) Considerando que se conoce la cantidad de alumnos; (b) Considerando que no se conoce con antelación el número de alumnos. Desarrolle un algoritmo y represéntelo utilizando pseudocódigo y alguna forma gráfica (diagrama de flujo, diagramamodular, etc.)

Pseudocódigo 1(a)
Inicio

# Inicialización de Variables

N=0 # Variable para contador
ALUMNOS=0 # Variable que toma el valor de la cantidad de alumnos
NOTA=0 # Variable que toma el valor de las notas de los alumnos
SUMA=0; # Variable que almacena la suma de notas de los alumnos
Promedio=0; # Variable quealmacena el valor del promedio de notas.

# Proceso

# Entrada de Dato

Escribir “Introduzca Cantidad de Alumnos a promediar”
Leer ALUMNOS;
N=0

Mientras N < ALUMNOS

Escribir “Introduzca nota del Alumno No %”,N+1
Leer NOTA;
SUMA= SUMA + NOTA
N= N+1
Fin Mientras
PROMEDIO = SUMA/N

# Salida

Escribir “El promedio deNotas de los Alumnos es: %”, PROMEDIO
Fin

Diagrama 1(a)

EJERCICIO Nº 2
2.- Desarrolle un algoritmo y represéntelo utilizando pseudocódigo y alguna forma gráfica (Diagrama de flujo, diagrama modular, etc.) que permita generar una tabla que muestre la equivalencia de temperaturas entre la escala Celsius y las escalas Farenheit y kelvin, en un rango particular Celsius y siguiendo un incrementoque pueda ser configurable. Para hacer las conversiones, recuerde que F= 1,8*C + 32 mientras que K= C + 273.

Pseudocódigo
Inicio
# Inicialización de Variables

VInicialC=0; # Variable que toma el valor Inicial del Grado Celsius
VFinalC=0; # Variable que toma el valor Final del Grado Celsius
C=0; # Variable de control de ciclo que toma las temperaturas Celsius
F=0;# Variable que toma el valor en Grado Farenheit
K=0; # Variable que toma el valor en Grado Kelvin

# Entrada

Escribir “Introduzca la temperatura inicial en grado Celsius”

Leer VInicialC;

Escribir “Introduzca la temperatura final en grado Celsius”

Leer VFinalC;

# Proceso

Para C= VInicialC hasta VFinalC hacer
F= 1,8*C + 32;
K= C + 273;# Salida

Escribir “ºC” , C
Escribir “ºF” , F
Escribir “ºK” , K
Fin Para
Fin

EJERCICIO Nº 3
3.- Diseñe un algoritmo y represéntelo utilizando pseudocódigo y alguna forma gráfica (Diagrama de flujo, diagrama modular, etc.) que acepte una serie de números hasta recibir un cero (0) y luego los ordene en forma ascendente.

Pseudocódigo
Inicio

Variables
Num[ ]( 1…n{Serie de números naturales}
Salir (0

Condiciones:
Hasta n = 0

Inicio
Mientras num 0 hacer
Introduzca num
V[](num
Fin mientras
Mientras Salir= 1 hacer
Salir(1
Para i(1 hasta n-1 hacer
Leer V[i]
Si V[i] > V[i+1] then
Aux ( V[i+1]
V[i+1]( V[i]
V[i](AuxSalir (0
Fin si
Fin para
Fin mientras
Escribir V[]
Fin del algoritmo

EJERCICIO Nº 4
4.- Diseñe un algoritmo y represéntelo utilizando pseudocódigo y alguna forma gráfica (Diagrama de flujo, diagrama modular, etc.) para simular el juego de lanzamiento de datos. Las reglas son las siguientes. Hay dos formas de obtener un 7.
I. Lanzar los dados y obtener 7 u 11en el primer lanzamiento
II. Lanzar los dados y obtener 4,5,6,8 ó 10 en el primer lanzamiento y luego obtener el mismo número en un lanzamiento posterior antes de obtener un 7.
Asimismo, hay dos formas de perder:
I. Lanzar los dados y obtener 2,3 ó 12 ene l primer tiro
II. Lanzar los dados y obtener 4,5,6,8 ó 10 en el primer lanzamiento y luego obtener 7 antes de obtener el mismo número...
tracking img