Algoritmos

Solo disponible en BuenasTareas
  • Páginas : 3 (545 palabras )
  • Descarga(s) : 0
  • Publicado : 31 de enero de 2012
Leer documento completo
Vista previa del texto
1. Halle el área de un triangulo rectángulo si su base y altura son de un valor desconocido Pseudocódigo: Diagrama de flujo:

Algoritmo_ Aretri Inicio Variables: Double: a, h, b Proceso 1. Escribe“Ingrese la base” 2. Escribe “Ingrese la altura” 3. Leer (b, h) 4. a (b*h)/2 5. Escribe”El área es:”, a Fin Algoritmo_Aretri

Diagrama de cajas: Inicio Double: b, h, a Escribe ‘ingrese la base y laaltura del triangulo’ Leer (b, h) A (b*h)/2

Escribir ‘el área del triangulo es: ’, a Fin

2. Leer cinco números y determinar su promedio. Pseudocódigo: Algoritmo Prom Inicio Constantes: Entero p 5Variable Entero n1, n2, n3, n4, n5, sum, prom Proceso 1. Escribir “Ingrese 5 números enteros” 2. Leer (n1, n2, n3, n4, n5) 3. Sum (n1+n2+n3+n4+n5) 4. Prom sum/p 5. Escribe “El promedio es:”, prom FinAlgoritmo Prom Diagrama de Flujo:

Diagrama de cajas:
Inicio Entero: n1, n2, n3, n4, n5, sum, prom P 5

Escribir ‘Ingrese 5 números enteros’ Leer (n1, n2, n3, n4, n5) Sum n1+n2+n3+n4+n5 P sum/pEscribe ‘El promedio es:’, prom Fin

2

3. Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor si es el caso.

Pseudocódigo:
Algoritmo MnMy Inicio Variables:Entero a, b Proceso 1. Escribe “ingrese dos números” 2. Leer a, b 3. Si a=b entonces Si si Escribir a=b Si no a>b entonces Si si escribir a, b Si no escribir b, a Fin Algoritmo MnMy

Diagrama deFlujo:

Diagrama de cajas
Inicio Entero a, b Escribir ‘ingrese dos números enteros’ Leer (a, b) a=b a>b Escribir b,’>’,a Fin

No

Si

Si Escribir a,’>’,b

No Escribir a,’=’, b

3

4.Calcule el valor de la hipotenusa de un triangulo rectángulo.
Pseudocódigo: Algoritmo Hipotenusa Inicio Variables: Double: c1, c2, sum, hip Proceso 1. Escribe “Ingrese valor de catetos” 2. Leer (c1, c2)3. Sum (c1^2) + (c2^2) 4. Hip sqrt (sum) 5. Escribe “hip” Diagrama de Flujo

Fin de algoritmo hipotenusa

Diagramas de cajas:
Inicio Double: c1, c2, sum, hip Escribir ‘Ingrese el valor de...
tracking img