Algoritmos

Solo disponible en BuenasTareas
  • Páginas : 2 (459 palabras )
  • Descarga(s) : 0
  • Publicado : 25 de octubre de 2010
Leer documento completo
Vista previa del texto
ORFA NELLY URREA CIRO
Metodología de la programación
ACTIVIDAD Nº 4

La fábrica de cartón Ciudad de París desea obtener la información de sus n empleados del departamento de producción para poderdeterminar al empleado más sobresaliente del mes y darle un bono de productividad de $3000, Desarrollar un algoritmo y diagrama de flujo que lea el nombre del empleado y las unidades producidasdurante el mes y calcular el promedio de producción, total de días arriba del promedio, cantidad producida más alta y el día más productivo. Mostrar el nombre del empleado, la producción por día, elpromedio de producción, el total de días arriba del promedio, la cantidad producida más alta y el día más productivo.

Algoritmo

Inicio
Leer N
Para I= 1 hasta N
Leer Nom,P
May=P
Sum=P
Dia=1Para L= 2 hasta 30
Leer
Si P>May entonces
May=P
Fin si
Sum=Sum+P
Fin para
Pro=Sum/N
Imprimir Dia,Pro,May
Fin para
Fin

Diagrama de flujo

El maestro de la clase de Matemáticasquiere obtener un reporte de sus alumnos del examen que les aplico de matemáticas, el maestro acomodó a sus alumnos en cinco 5 hileras y cada hilera con 5 asientos, el reporte que el maestro desea obteneres el promedio de los alumnos colocados por hilera y la calificación más alta y mas baja. Desarrollar un algoritmo y diagrama de flujo que pida al usuario las calificaciones de los alumnos. Después elprograma debe dar la opción de calcular el promedio de las calificaciones de los alumnos por hilera, obtener la calificación más alta y más baja. Mostrar el arreglo de los alumnos con suscalificaciones, el promedio de calificaciones por hilera y la calificación más alta y más baja.

Algoritmo
Inicio
May = A(1)
Men = A(1)
Sum = 0
Para I= 1 hasta 5 haga
Sum = 0
Para L = 1 hasta 5
LeoA(I,L)
Sum = Sum +A(I,L)
Si A(I,L) > May entonces
May = A(I,L)
Si no
Si A(I,L) < Men entonces
May = A(I,L)
Fin si
Fin si
PRO = Sum / 5
Imprimir PRO
Fin para
Fin para
Imprimo May, Men...
tracking img