Analisis estructurado moderno

Solo disponible en BuenasTareas
  • Páginas : 6 (1498 palabras )
  • Descarga(s) : 7
  • Publicado : 8 de agosto de 2010
Leer documento completo
Vista previa del texto
TRABAJO PRÁCTICO

PROF: ING. GERMANO SOARES D.

ALUMNOS:
* RICARDO GASTON PEREIRA
* ALEXIS F. ESTIGARRIBIA P.

CURSO: 3°
SEMESTRE: 5°

AÑO: 2.010

Declaración de Propósitos
Este sistema tiene como objetivo registrar el ingreso de denuncias de hechos punibles correspondientes al área penal. Como también el registro de los datos del denunciante, deldenunciado (o personas innominadas), del tipo de hecho punible y la correspondiente asignación en forma automática del número de entrada o numero de causa. Cabe destacar la importancia de este sistema ya que con esto se podrá individualizar rápidamente la unidad fiscal encargada de la investigación de dicha carpeta. Además otra importancia en que radica es que se podrá elaborar las estadísticas de lascausas penales, hechos punibles, propias de cada zona; para el posterior estudio y análisis de los profesionales del área.

Diagrama de Contexto

Lista de Acontecimientos
SISTEMA – DENUNCIANTE
1. El denunciante registra sus datos personales.
2. El denunciante registra la denuncia.
3. El denunciante registra ampliación de denuncia.
4. Emisión de constancia.

SISTEMA –FISCALIA ADJUNTA
5. Registro y control de Agentes Fiscales
SISTEMA – UNIDAD FISCAL
6. Asignación de carpeta fiscal
7. Devolución por inhibición
8. Emisión de resumen por hechos punibles
9. Emisión de resumen por Agente Fiscal
10. Emisión de resumen por unidad fiscal
SISTEMA – ADMINISTRACION CENTRAL DE MESA DE ENTRADA
11. La administración recibe histórico dedenuncia por hecho punible
12. La administración recibe informes

Diagrama Flujo de Datos
Proceso 1. El denunciante registra sus datos personales.

Proceso 2. Registra la denuncia.

Proceso 3. Ampliación de la denuncia.

Proceso 4. Emisión de constancia

Proceso 5. Registro y control de Agentes Fiscales.

Proceso 6. Asignación de carpeta fiscal.

Proceso 7. Devolución porinhibición.

Proceso 8. Emisión de resumen por hechos punibles.

Proceso 9. Emisión de resumen por Agente Fiscal.

Proceso 10. Emisión de resumen por unidad fiscal.

Proceso 11. Emitir histórico de denuncias por hecho punible.

Proceso 12. Envía informes.

Especificaciones de Procesos

Proceso 1. Registrar denunciante
Inicio
Si CI_denunciante = “nuevo”entonces
Añadir datos del denunciante a denunciante
Si no
Mensaje error “denunciante no existe”
Fin si
Fin

Proceso 2. Procesar denuncia
Inicio
Si CI_denunciante = “valido” entonces
Guardar registro de la denuncia en denuncia
Si no
Mensaje error “denunciante no existe”
Fin si
Fin

Proceso 3. Procesar ampliación
Inicio
Leer denuncia
Si ampliación dedenuncia = “valido” entonces
Actualizar denuncia
Fin si
Fin

Proceso 4. Emite constancia
Inicio
Leer denuncia
Si denuncia = “valido” entonces
Emitir constancia
Fin si
Fin

Proceso 5. Proceso de registro y control
Inicio
Leer registro y control de agentes fiscales
Si registro y control de agente fiscal = “valido” entonces
Añadir datos de agente fiscal aagente fiscal
Fin si
Fin
Proceso 6. Procesar asignación
Inicio
Si asignación = “verdadero” entonces
Asignar carpeta fiscal a unidad fiscal
Fin si
Fin

Proceso 7. Procesar devolución
Inicio
Si devolución por inhibición = “verdadero” entonces
Volver a hacer sorteo y asignar a unidad fiscal
Fin si
Fin

Proceso 8. Procesar Resumen
Inicio
Leer emisión
Siresumen por hecho punible = “pedido” entonces
Emitir resumen por hecho punible
Fin si
Fin

Proceso9. Procesar resumen
Inicio
Si Agente Fiscal = ” nombre de Agente Fiscal” entonces
Emitir resumen por Agente Fiscal
Fin si
Fin
Proceso 10. Procesar resumen
Inicio
Si unidad fiscal = ” numero de unidad fiscal” entonces
Emitir resumen por unida fiscal
Fin si...
tracking img