Arreglos

Solo disponible en BuenasTareas
  • Páginas : 19 (4690 palabras )
  • Descarga(s) : 0
  • Publicado : 30 de abril de 2011
Leer documento completo
Vista previa del texto
Programación I
Series de Trabajos Prácticos: Seudocódigo

Serie 3: Arreglos

Ejercicio 1

Comenzar
Imprimir “Número”, “Característica”
Leer V(I); I=1,15
Para I Desde 1 Hasta 15
Si I/2 = [I/2] Entonces
Si V(I)>0 Entonces
LEYEN = “Positivo de posición par”
Fin_Si
Si_No
Si V(I)0 Entonces
Sum = Sum + B(I)
Fin_Si
Fin_Para I
Imprimir “La suma de loselementos positivos del vector es”, Sum
Parar

Ejercicio 3

Comenzar
Leer N
Leer A(I); I=1,N
Para I Desde 1 Hasta N
B(I) = A(N - I + 1)
Fin_Para I
Parar

Ejercicio 4

Comenzar
CL = 0
A(1) = “X”
A(2) = “Y”
A(3) = “Z”
A(4) = “x”
A(5) = “y”
A(6) = “z”
Leer N
Leer CAD(I); I=1,N
Para I Desde 1 Hasta N
Para J Desde 1 Hasta 6
Si CAD(I) = A(J) Entonces
CL =CL + 1
Fin_Si
Fin_Para I
Fin_Para J
Imprimir “El número de veces que aparecen las letras es:”, CL
Parar

Ejercicio 5

Comenzar
S = 0
Leer A(I,J); I=1,10, J=1,8
Para I Desde 1 Hasta 10
Para J Desde 1 Hasta 8
S = S + A(I,J)
Fin_Para J
Fin_Para I
Imprimir “La suma de los elementos de la matriz es:”, S
Parar

Ejercicio 6

Comenzar
Imprimir “Tablas deMultiplicar”
Para I Desde 1 Hasta 10
Para J Desde 1 Hasta 10
M(I,J) = I * J
Fin_Para J
Imprimir “Tabla del”, I
Imprimir M(I,J); J=1,10
Fin_Para I
Parar

Ejercicio 7

Comenzar
Leer M, N, P
C(I,J) = 0; I=1,M, J=1,P
Leer A(I,J), B(I,J); I=1,M, J=1,N, K=1,P
Para I Desde 1 Hasta M
Para J Desde 1 Hasta P
Para K Desde 1 Hasta N
C(I,J) = C(I,J) + A(I,K) * B(K,J)Fin_Para K
Fin_Para J
Fin_Para I
Para I Desde 1 Hasta M
Imprimir C(I,J); J=1,P
Fin_Para I
Parar

Ejercicio 8

Comenzar
Leer K, L
Si K = L Entonces
Leer A(I,J); I=1,10, J=1,K
Leer B(I,J); I=1,10, J=1,L
C(I,J) = 0; I=1,10, J=1,K
Para I Desde 1 Hasta 10
Para J Desde 1 Hasta K
C(I,J) = A(I,J) + B(I,J)
Fin_Para J
Imprimir C(I,J); J=1,K
Fin_Para ISi_No
Imprimir “Las matrices no pueden sumarse.”
Fin_Si
Parar

Ejercicio 9

Comenzar
V(I) = 0; I=1,15
Leer D(I,J); I=1,15, J=1,4
Imprimir “Matriz”, “Vector”
Para I Desde 1 Hasta 15
Para J Desde 1 Hasta 4
V(I) = V(I) + D(I,J)
Fin_Para J
Imprimir D(I,J), V(I); J=1,4
Fin_Para I
Parar

Ejercicio 10

Comenzar
Leer N, M
Leer A(I,J); I=1,N, J=1,M
I = 1
K = NRepetir Hasta I = [N/2]
Para J Desde 1 Hasta M
AUX = A(I,J)
A(I,J) = A(K,J)
A(K,J) = AUX
Fin_Para J
I = I + 1
K = K - 1
Fin_Repetir
Imprimir “Matriz Resultante”
Para I Desde 1 Hasta N
Imprimir A(I,J); J=1,M
Fin_Para I
Parar

Ejercicio 11

Comenzar
Leer A(I,J); I=1,3, J=1,12
B(J) = 0; J=1,12
M(I) = 0; I=2,3
Para J Desde1 Hasta 12
Para I Desde 1 Hasta 3
B(J) = B(J) + A(I,J)
Fin_Para I
Fin_Para J
Para I Desde 2 Hasta 3
Para J Desde 1 Hasta 12
M(I) = M(I) + A(I,J)
Fin_Para J
M(I) = M(I) / 12
Fin_Para I
Imprimir “Costos de producción anual”
Para I Desde 1 Hasta 3
Imprimir A(I,J); J=1,12
Fin_Para I
Imprimir “Suma de costos anuales de producción”
ImprimirB(J); J=1,12
Imprimir “Promedio anual de costos de bebidas:”, M(2)
Imprimir “Promedio anual de costos de conservas:”, M(3)
Parar

Ejercicio 12

Comenzar
Leer N
Leer P(I), C(I), A(I); I=1,N
I = 1
Leer Nom, Ciu, Art
Repetir Mientras NomP(I)
I = I + 1
Fin_Repetir
Si CiuC(I) Entonces
C(I) = Ciu
Fin_Si
Si ArtA(I) Entonces
A(I) = Art
Fin_Si
Imprimir “Proveedor:”,P(I), “Ciudad:”, C(I), “Cantidad de artículos que provee:”, A(I)
Parar

Comenzar
Leer N
Leer P(I), C(I), A(I); I=1,N
I = 1
Leer Nom
Repetir Mientras NomP(I)
I = I + 1
Fin_Repetir
Para J Desde I Hasta N - 1
P(J) = P(J + 1)
C(J) = C(J + 1)
A(J) = A(J + 1)
Fin_Para J
Parar

Serie 4: Pilas y Colas

Ejercicio 1

Comenzar

Leer PILA(I); I=1,126
Para TOPE...
tracking img