Colas

Solo disponible en BuenasTareas
  • Páginas : 2 (312 palabras )
  • Descarga(s) : 0
  • Publicado : 18 de diciembre de 2011
Leer documento completo
Vista previa del texto
paquete cola
clase metodos ()
propiedades
array: Gcola[100]
dato: Gdato
string: Gsr
double: I; aux
método
+validar(Gcola[100];Gsr)
{
i<-1 ; aux<-0
mientras (i<=100)hacersi (Gcola[i] = ’_’) entonces
aux<-aux+1
finsi
i<-i+1
finmientras
si (aux=100) hacer
Gsr<-‘Cola Vacia’
Return Gsr
finsi
si (aux<100) hacer
Gsr<-‘ed’
ReturnGsr
finsi
Si (aux = 0) entonces
Gsr<-‘Cola llena’
Return Gsr
finsi
}
+colocarpush(Gdato;Gcola[100])
{
i<-1
mientras (i<=100)hacer
si (Gcola[i] <> ’_’)entonces
i<-i+1
sino
aux<-i
i<-101
finsi
finmientras
Gcola[aux]<-Gdato
mostrar ‘Dato agregado’
}
+pop(Gcola[100])
{
i<-1
mientras (i<100) hacerGcola[i]<-Gcola[i+1]
i<-i+1
finmientras
Gcola[100]<- ‘_’
mostrar ’Dato eliminado’
}
+imprimir(Gcola[100])
{
i<-1
mientras (i<=100) hacer
mostrarGcola[i]
i<-i+1
finmientras
}
+buscar(Gdato;Gcola[100])
{
i<-1
mientras (i<=100) hacer
si (Gcola[i]=Gdato) entonces
mostrar i && Gdato
finsii<-i+1
finmientras
}
+popultimo(Gcola[100])
{
i<-1
mientras (i<=100)hacer
si (Gcola[i] <> ’_’) entonces
i<-i+1
sino
aux<-i
i<-101
finsifinmientras
Gcola[aux-1]<-‘_’
mostrar ‘Dato eliminado’
}
+popdato(Gdato;Gcola[100])
{
i<-1
mientras (i<=100) hacer
si (Gcola[i]=Gdato) entonces
aux<-imientras (aux<100) hacer
Gcola[aux]<-Gcola[aux+1]
aux<-aux+1
finmientras
Gcola[100]<-‘_’
Finsi
i<-i+1
finmientras
mostrar ‘Dato(s) eliminado(s)’}
+popubicacion(Gubi;Gcola[100])
{
mientras (Gubi<100) hacer
Gcola[Gubi]<-Gcola[Gubi+1]
Gubi<-Gubi+1
finmientras
Gcola[100]<-‘_’
mostrar ‘dato eliminado’...
tracking img