Conjuntos dimensionados

Solo disponible en BuenasTareas
  • Páginas : 3 (723 palabras )
  • Descarga(s) : 0
  • Publicado : 21 de febrero de 2011
Leer documento completo
Vista previa del texto
Conjuntos dimensionados
 




1. Introducción a los conjuntos dimensionados 2. Conjuntos unidimensionados: Los vectores 3. Operaciones con vectores 4. Conjuntos multidimensionales: Lasmatrices

2

1. Introducción a los conjuntos dimensionados
 






Permiten manejar gran cantidad de datos Utilizan un mismo identificador Evitan utilizar muchas variables Tipos deconjuntos: Vectores (1 dimensión) Matrices (2 dimensiones) Multidimensionales (3 ó más dimensiones) Son conjuntos finitos y ordenados de elementos homogéneos

3

2. Conjuntos unidimensionados: Losvectores
V(1) V(2) V(3) … V(N)

V

5 -3 -1 14 … 23 Memoria

4

2. Conjuntos unidimensionados: Los vectores




Declaración variables reales V(100) variables enteras U(100) variableslógicas W(100) Acceso V(2)  5.8 V(3)  V(2) – V(1)

5

3. Operaciones con vectores
Lectura de vectores

Leer (V(1)) Leer(V(31)) I 55 Leer (v(i))

para i hasta 100 hacer leer (V(i)) finpara

6 3. Operaciones con vectores
Escritura de vectores

para i escritura (V(1)) escritura(V(31)) I 55 escritura (v(i))

hasta 100 hacer escribir (V(i)) finpara

7

3. Operaciones con vectores 

Ejemplo: Suma de dos
vectores

Algoritmo SumaVectores

variables enteras v(100), u(100) variables enteras w(100), i para i 1 hasta 100 hacer leer(v(i), u(i)) finpara
para i  1 hasta100 hacer w(i)  v(i) + u(i) finpara

8

para i  1 hasta 100 hacer escribir(w(i)) finpara finalgoritmo

Problemas
 


 

Encontrar el máximo y el mínimo en un vector Producto escalarde dos vectores Calcular la media de un vector Invertir las posiciones de un vector Contar el número de elementos negativos y positivos en un vector

9

Problemas



 

Contar el númerode veces que aparece un número en un vector Determinar la posición del máximo dentro de un vector Calcular los 100 primeros números de Fibonacci Desplazar los elementos de un vector una posición a...
tracking img