Ejemplo de algoritmos

Solo disponible en BuenasTareas
  • Páginas : 5 (1136 palabras )
  • Descarga(s) : 0
  • Publicado : 2 de noviembre de 2010
Leer documento completo
Vista previa del texto
Contar los números enteros positivos introducidos por teclado. Se consideran dos variables enteras NUMERO y CONTADOR (contará el número de enteros positivos).  Se supone que se leen números positivos y se detiene el bucle cuando se lee un número negativo o cero.
Pseudocódigo
                Inicio
                  contador 0
                   Leer (numero)
                  Mientrasnumero > 0 hacer
                        contador  contador+1 
                       Leer (numero)
                    Fin_Mientras
                   Escribir('El número de enteros positivos es : ', contador)
                    Fin
 
Diagrama de Flujo – 1er. Ejemplo

Preguntar un nombre y repetirse en pantalla tantas veces como se desee. (preguntar cantidad de repeticiones),indicando el número de repetición.
Declaración de variables
Cadena : nom
entero : x, n
Inicio
escribir(‘Nombre : ‘)
leer(nom)
escribir(‘Cuántas veces quieres repetirlo ? : ‘)
leer(n)
para x 1 hasta n hacer
     escribir(x’.- ‘, nom)
Fin

un trabajador le descuentan de su sueldo el 10% si su sueldo es
menor o igual a 1000. por encima de 1000 y hasta2000 el 5% del
adicional, y por encima de 2000 el 3% del adicional. calcular el
descuento y sueldo neto que recibe el trabajador dado su sueldo.

variables: sueldo,sueldo_neto,descuento
inicio
leer: sueldo
si: sueldo <= 1000 entoncesdescuento <-- sueldo * 0.1
si_no
si: sueldo <= 2000 entonces
descuento <-- (sueldo - 1000) * 0.05 + 1000 * 0.1
si_no
descuento <-- (sueldo - 2000) * 0.03 + 1000 * 0.1fin_si
imprimir: descuento.
fin

Realizar un algoritmo que permita pedir
50 números naturales y determine e imprima cuantos son
pares, impares, positivos y negativos.

variables:par(p), impares(im), positivos(pos), negativos(n)
Inicio
p= 2
in= 0
pos.= 0
n= 0Para x= 1 hasta 50
Leer n
Si n mod 2= 0 entonces
p= p + 1
Sino
in= in + 1
Finsi
Si n > 0 entonces
Pos= pos + 1
Sino
n= n + 1
Finsi
Fin_para
Escribir p, in, pos, n
Fin

Algoritmo para hallar el Área de un trapecio
1. inicio
2. pedir valor de la base mayor = BMA
3. pedir valor de la base menor = BME
4.pedir valor de la altura = H
5. proceso:
A ((BMA+BME))*H)/2

6. imprimir resultado A
7. fin

Algoritmo para hallar el Área de un triangulo

1. inicio
2. pedir base =B
3. pedir altura =H
4. proceso
A = (B*H)/2
5. imprimir resultado A
6. fin.

Realizar algoritmo para pedir dos datos numéricos hacer su suma, su resta, su multiplicación y división, imprimir resultados.

1. inicio2. pedir valor del dato numérico “A”
3. pedir valor del dato numérico “B”
4. proceso
C=A+B
D=A*BV
M=A/B
R=A-B
5. imprimir resultado de “C,D,M,B”
6. Fin

Pedir un numero , escribir , imprimir si el numero es positivo o negativo

1.- inicio

2.- leer ( dame el valor de un número)

3.-condición
Si N >0 entonces
Imprimir positivo
De lo contrario
Imprimir negativo
FinHacer un programa que calcule al suma de los n primeros números naturales

S = 1 + 2 + 3 + 4 . . . . . .n

Inicio
Leer n
Suma <- 0
Desde i <- 1 hasta n hacer...
tracking img