Ejemplos de algoritmos

Solo disponible en BuenasTareas
  • Páginas : 5 (1188 palabras )
  • Descarga(s) : 0
  • Publicado : 21 de marzo de 2011
Leer documento completo
Vista previa del texto
1.- Diseñar un algoritmo que calcule la suma de la serie:

1 + 3 + 6 + 9 + 12 + … + 144

INICIO
contador=3
suma=0
MIENTRAS (contador<=144) HACER
suma=suma+contador
contador=contador+3
FIN_MIENTRAS
suma=suma+1
Escribir(suma)
FIN

(Rodríguez Rodríguez) 2.- Diseñar un algoritmo que calcule la suma de la serie:5+10 +15+20+…+N
INICIO
Leer(N)
contador=5
suma=0
MIENTRAS (contador<=N) HACER
suma=suma+contador
contador=contador+5
FIN_MIENTRAS
Escribir(suma)
FIN

3.- Diseñar un algoritmo que calcule el producto de los números impares entre 1 y N (número entero)

INICIO
Leer(N)
contador=1
producto=1
MIENTRAS (contador<=N) HACERproducto=producto*contador
contador=contador+2
FIN_MIENTRAS
Escribir(producto)
FIN

4.-Diseñar un algoritmo que calcule la suma de la serie:
1 + 1/2 + 1/4 + 1/6 + 1/8 + 1/10 + 1/12 + … + 1/N
Donde N es un valor entero introducido mediante el teclado.

INICIO
Leer(N)
suma=0
contador=2
MIENTRAS (contador<=N) HACER
suma=suma+1/contador
contador=contador+2
FIN_MIENTRASsuma=suma+1
Escribir(suma)
FIN


5.- Diseñar un algoritmo que calcule la suma de los números impares entre 11 y N (valor entero leído del teclado).

INICIO
Leer(N)
suma=0
contador=11
MIENTRAS (contador<=N) HACER
suma=suma+contador
contador=contador+2
FIN_MIENTRAS
Escribir(suma)
FIN

6.- Diseñar un algoritmo que lea una serie de números y calcule la suma de los númerosenteros positivos, el algoritmo se detiene cuando se ingresa un número negativo.

INICIO
Leer(numero)
suma=0
MIENTRAS (numero>=0) HACER
suma=suma+numero
Leer(numero)
FIN_MIENTRAS
Escribir(suma)
FIN

7.- Diseñar un algoritmo para el problema 5, usando la instrucción HACER_MIENTRAS.

INICIO
Leer(N)
suma=0
contador=11
HACER
suma=suma+contador
contador=contador+2
MIENTRAS(contador<=N)
FIN_HACER_MIENTRAS
Escribir(suma)
FIN

8.- Diseñar un algoritmo que lea una serie de números y calcule la suma de los números pares, el algoritmo se detiene cuando se ingresa un número negativo o cero.

INICIO
Leer(numero)
suma=0
MIENTRAS (numero>0) HACER
SI (numero mod 2==0) ENTONCES
suma=suma+numero
FIN_SI_ENTONCES
Leer(numero)
FIN_MIENTRAS
Escribir(suma)
FIN9.- Diseñar un algoritmo que calcule el promedio de una lista de calificaciones. La lista termina cuando se ingresa el número -99.

INICIO
Leer(calificación)
suma=0
n=0
MIENTRAS (calificación <> -99) HACER
Suma=suma+calificación
N=n+1
Leer(calificación)
FIN_MIENTRAS
Promedio=suma/n
Escribir(promedio)
FIN

) 10.- Diseñar un algoritmo que calcule el factorial de un número N.INICIO
Leer(N)
factorial=1
i=1
DESDE(i=1; i<=N; i=i+1)HACER
Factorial=factorial*i
FIN_DESDE
Escribir(factorial)
FIN

11.- Diseñar un algoritmo que calcula el porcentaje de aprobados en una clase, a partir del promedio de 40 alumnos.

INICIO
contadoralumnos=1
contadoraprobados=0
MIENTRAS (contadoralumnos<=40) HACER
Leer(promedio)
SI promedio >= 6 ENTONCEScontadoraprobados=contadoraprobados+1
FIN_SI_ENTONCES
contadoralumnos=contadoralumnos+1
FIN_MIENTRAS
porcentaje=contadoraprobados*100/40
Escribir(porcentaje)
FIN

12.- Diseñar un algoritmo que lea tres números y visualice en pantalla el valor del más grande. Se asume que los tres valores son diferentes.

INICIO
Leer(numero1,numero2,numero3)
SI (numero1>numero2 AND numero1>numero3)ENTONCESEscribir (numero1)
SINO
SI (numero2>numero1 AND numero2>numero3)ENTONCES
Escribir(numero2)
SINO
Escribir(numero3)
FIN_SI_ENTONCES_SINO
FIN_SI_ENTONCES_SINO
FIN

13.- Calcular el factorial de N números leídos del teclado.

INICIO
Leer(N)
DESDE (i=1; i<=N; i=i+1) HACER
Leer(numero)
Factorial=1...
tracking img