Estructuras de control de iteración
Desarrolle los siguientes algoritmos
1) Escribir un algoritmo que calcule e imprima la suma de los n primeros números naturales. El valor de n debe leerse del teclado.
2) Escribir un algoritmo para calcular el promedio de una lista de notas de una cantidad N de alumnos, y diga los aprobados, los desaprobados, la máxima nota y la mínima. La nota mínima para aprobar es 6
3) Escribir un algoritmo donde se puedan ingresar N números y los separe por los menores a 50 inclusive, los que están entre 51 y 100 inclusive y los mayores a 100. Imprimir los números con sus correspondientes mensajes.
4) Un supermercado promociona unproducto de la siguiente forma:
- Si el cliente lleva entre 2 y 5 unidades se realiza un 10% de descuento.
- Si lleva entre 6 y 10 unidades se realiza un 15% de descuento.
- Si lleva entre 11 y 20 unidades se realiza un 20% de descuento.
- Si lleva más de 20 unidades se realiza un 45% de descuento.
Realizar un algoritmo que resuelva los pasos anteriores y además imprima el precio unitario, el precio con descuento y la cantidad de productos, sabiendo que el precio del producto y la cantidad de productos se ingresan por teclado.

1) Escribir un algoritmo que calcule e imprima la suma de los n primeros números naturales. El valor de n debe leerse delteclado.

ENTEROS SUMA,Y,i,N
INICIO
Y=1
SUMA=0
LEER N
PARA i = 1 HASTA N HACER
SUMA=SUMA + Y
Y=Y+1
FIN PARA
ESCRIBIR “LA SUMA DE LOS”,N,”PRIMEROS NUMEROS NATURALES ES IGUAL A”,SUMA
FIN

2) Escribir un algoritmo para calcular el promedio de una lista de notas de una cantidad N de alumnos, y diga los aprobados, los desaprobados, la máxima nota y la mínima. La nota mínima para aprobar es 6

INICIO
APROBADOS=0
DESAPROBADOS=0
MAYOR=0
MENOR=10
PARA i=1 HASTA N HACER
LEER NOTA
SI NOTA >= 6 ENTONCES
APROBADOS=APROBADOS + 1
SINO
DESAPROBADOS=DESAPROBADOS+1
FIN SI
SI NOTA>=MAYOR
MAYOR=NOTA [continua]

Leer Ensayo Completo

Cite este ensayo

APA

(2012, 06). Ejemplos En Pseudocodigo. BuenasTareas.com. Recuperado 06, 2012, de http://www.buenastareas.com/ensayos/Ejemplos-En-Pseudocodigo/4534695.html

MLA

"Ejemplos En Pseudocodigo" BuenasTareas.com. 06 2012. 2012. 06 2012 <http://www.buenastareas.com/ensayos/Ejemplos-En-Pseudocodigo/4534695.html>.

MLA 7

"Ejemplos En Pseudocodigo." BuenasTareas.com. BuenasTareas.com, 06 2012. Web. 06 2012. <http://www.buenastareas.com/ensayos/Ejemplos-En-Pseudocodigo/4534695.html>.

CHICAGO

"Ejemplos En Pseudocodigo." BuenasTareas.com. 06, 2012. consultado el 06, 2012. http://www.buenastareas.com/ensayos/Ejemplos-En-Pseudocodigo/4534695.html.