Ejemplos pseudocodigo

Solo disponible en BuenasTareas
  • Páginas : 3 (579 palabras )
  • Descarga(s) : 7
  • Publicado : 24 de agosto de 2010
Leer documento completo
Vista previa del texto
1
Algoritmo suma decremental
/*Permite el ingreso de dos numeros el primero debe ser mayor que le segundo y luego debe ejecutar la sumatoria de los numeros comprendidos entre ambos.*/
ModulosIncluidos
EntradaYSalida
Variables
Entero: num1, num2, sumatoria, i

INICIO
Escribir(‘Ingresar Primer numero’)
Obtener(num1)
Escribir(‘Ingresar Segundo numero’)Obtener(num2)
SI num1 > num2 ENTONCES
DESDE i ( num1 DISMINUYENDO HASTA num2 HACER
sumatoria ( sumatoria + i
FIN DESDE
Escribir (“La Sumatoria es “ + Sumatoria)
SINOEscribir (“Numeros Invalidos para efectuar la Sumatoria. El primero debe ser mayor que el segundo”)
FIN SI
FIN ALGORITMO

3.6
ALGORITMO Multiplicar con sumas consecutivas
/*Permite el ingreso dedos números los cuales servirán para realizar la sumatoria del 2do numero la cantidad de veces del primer numero.*/
Modulos Incluidos
EntradaYSalida
Variables
Entero: num1, num2, resultado, iINICIO
Escribir(‘Ingresar Primer numero’)
Obtener(num1)
Escribir(‘Ingresar Segundo numero’)
Obtener(num2)
DESDE i ( 1 HASTA num1 HACER
resultado ( resultado + num2FIN DESDE
Escribir (“El Resultado “ + resultado)
FIN ALGORITMO
3.7
ALGORITMO Dividir con restas sucesivas
/*Permite el ingreso de dos números los cuales servirán para realizar las restassucesivas del 2do numero la cantidad de veces del primer numero.*/
Modulos Incluidos
EntradaYSalida
Variables
Entero: num1, num2, resultado, i, contador

INICIO
Escribir(‘Ingresar Primernumero’)
Obtener(num1)
Escribir(‘Ingresar Segundo numero’)
Obtener(num2)
DESDE i ( num1 DISMINUYENDO HASTA 0 SALTOS DE num2 HACER
resultado ( i - num2
SI resultado = 1ENTONCES
i ( 0
FIN SI
contador ( contador + 1
FIN DESDE
Escribir (“El Resultado de dividir “ + num1 + “ entre “ + num2 + “ es “ + contador)
FIN ALGORITMO
3.8
ALGORITMO Factorial de...
tracking img