Ejercicios de algoritmos

Solo disponible en BuenasTareas
  • Páginas : 107 (26682 palabras )
  • Descarga(s) : 0
  • Publicado : 11 de enero de 2011
Leer documento completo
Vista previa del texto
1.- Hacer un programa que al dar la hora hh, mm, ss, muestre las
horas, minutos y segundos y también nos calcuel la hora
despues de 2 segundos.

inicio
leer hh, mm, ss
si (hh < 24) y (mm<60) y (ss>60) entonces
ss <-- ss + 2
si ss = 60 entoncesss <-- 0
mm <-- mm + 2
si mm = 60 entonces
mm <-- 0
hh <-- hh + 2
si hh = 24 entonces
hh <-- 0
fin_si
fin_si
fin_si
fin_Si
escribir hh, mm, ssfin


Autor:
Bellodas Leccaros

2.- Hacer un programa que lea 2 números y deducir si están en orden
creciente o decreciente.

inicio
leer a, b
si a <= b entonces
escribir "orden creciente"
si_no
escribir "orden decreciente"
fin_si
fin

Autor:
Bellodas leccaros

3.- Calcular el númeromayor de una lista de números.

real: UM, MAX
entero: I, N

inicio
leer N // N >0
leer NUM
MAX <-- NUM
desde I <-- 2 hasta 100 hacer
leer NUM
si NUM > MAX entonces
MAX <-- NUM
fin_si
fin_desde
fin

Autor:
Bellodas leccaros

4.- De una lista de 100 números determinar simultaneamente
el máximo y mínimo número.

I: entero
MAX, MIN, NÚMERO: realinicio
leer NUMERO
MAX <-- NUMERO
MIN <-- NUMERO
desde I <-- 2 hasta 100 hacer
leer NUMERO
si NUMERO > MAX entonces
MAX <-- NUMERO
sino
si NUMERO < MIN entonces
MIN <-- NUMERO
fin_si
fin_si
fin_desde
escribir "máximo", MAX, "mínimo", MIN
fin

Autor:
Bellodas leccaros
5.-Se ingresan 5 notas de un alumno, publicar 2 peores notas.inicio
dimensionar a[100]
x <-- 1
mientras x <= 5 hacer
leer a[x]
x <-- x + 1
fin_mientras

x <-- 1
mientras x <= 5 hacer
y <-- 1
mientras y <= 5 hacer
si a[x] < a[y] entonces
T <-- a [x]
a[x]<-- a[y]
a[y] <-- T
fin_si
y <-- y + 1
fin_mientras
y <-- y + 1
fin_mientras

//publicar

x <-- 5mientras x >= 2 hacer
escribe a [x]
x <-- x + 1
fin_mientras
fin

Autor:
Bellodas leccaros

6.- ¿Calcular las raices de una ecuacion de segundo grado(a²+bx+c=0)?
variables
a,b,c,x¹,x²

inicio
leer a,b,c
d_(b²)-(4*a*c)
si a<>0 y d>=0 entonces
x¹_(-b+sqrt(d))\(2*a)
x²_(-b-sqrt(d))\(2*a)
imprimir x¹,x²
sinoimprimir"no se efectua la operacion"
fin si
fin

7.- ¿Dada la duracion en minutos de una llamada calcular el costo,considerando?
-Hasta tres minutos el costo es 0.50
-Por encima de tres minutos es 0.50 más 0.1*cada minuto adicional a los tres primeros

variables
M,C

inicio
leer M
si M<=3
C_0.50
sino
C_0.50+0.1*(M-3)fin si
imprimir el "C"
fin

Autor:
Nadezhda Espada Flores

8.- ¿Dado tres numeros calcular el mayor?

variables
n1,n2,n3,M

inicio
leer n¹,n²,n³
si n¹>n² y
n¹>n³ entonces
mayor_ n¹
sino
fin si
si n²>n¹ y n²>n³ entonces
mayor_ n²
sino
mayor_ n
fin si
imprimir mayor
finAutor:
Nadezhda Espada Flores

9.- ¿Dada N notas calcular el promedio de las notas aprovadas y el promedio de las notas desaprovadas?

variables
N,C,S,I,nota,S¹,S²,Pa,Pd

inicio
leer N
I_1
S¹_0
S²_0
C_0
S_0
mientras I<=N hacer
leer nota
si nota>=12 entonces
S¹_ S¹+nota
C_...
tracking img