Ejercicos de winlogo

Solo disponible en BuenasTareas
  • Páginas : 6 (1256 palabras )
  • Descarga(s) : 0
  • Publicado : 30 de agosto de 2010
Leer documento completo
Vista previa del texto
Ejercicios de Winlogo  
1.- Abre WinLogo y sitúate en la ventana de trabajo. Escribe las siguientes líneas:
• av 50
• gd 90
• av 50
• gi 90
• re 100
• av 20
• bp
2.- Sitúate en la ventana de trabajo y borra todo lo que hay escrito. Escribe a continuación las siguientes líneas:
• av 50
• gd 135
• av 70
• gi 225
• av 50
3.- Borra todoel contenido del área de trabajo y borra la pantalla. Abre la ventana de edición (Ventanas -> Edición). Escribe en esa área las órdenes siguientes:
• av 50
• gd 135
• av 70
• gi 225
• av 50
Observa como la tortuga no hace nada. Para que la tortuga interprete esas órdenes ve a Área -> Interpretar.
4.- Realiza el dibujo de un cuadrado de 60 de lado.
5.- Borra todo lo quehas escrito anteriormente y realiza a continuación el dibujo de un rectángulo de 80 por 40.
6.- Borra lo que has hecho en el ejercicio 5 y realiza a continuación el dibujo de un triángulo equilátero de 80 de lado.
7.- Abre WinLogo y sitúate en la ventana de trabajo. Escribe las siguientes líneas:
• av -50
• gd -90
• av 50
• gi -90
• re -100
• av 20
• bp
8.-Usando números negativos realiza el dibujo de un cuadrado de 60 de lado.
9.- Realiza el dibujo de un rectángulo de 80 por 40.
10.- Realiza el dibujo de un triángulo equilátero de 80 de lado.
11.- Abre WinLogo y sitúate en la ventana de trabajo. Escribe las siguientes líneas:
• av 50
• ot
• gd 75
• av 50
• mt
12.- Sitúate en la ventana de trabajo y borra todo lo que hayescrito. Escribe a continuación las siguientes líneas:
• bp
• gd 90
• av 30
• sl
• av 30
• bl
• av 20
• sl
• av 20
13.- Realiza el dibujo de un pentágono de 50 de lado. La tortuga deberá permanecer oculta al finalizar el pentágono.
14.- Realiza el dibujo de un rectángulo de 100 x 60 con trazos de 20 pasos cada uno.
[pic]
15.- Abre WinLogo y sitúate enla ventana de trabajo. Escribe las siguientes líneas:
• Pong 1
• Poncl 10
• Av 40
• Gd 90
• Av 40
• Gd 90
• Av 40
• Gd 90
• Av 40
• Gd 90
• Gd 30
• Av 3
• rellena
16.- Realiza el dibujo de un cuadrado de 60 de lado. Cada lado debe tener un color y un grosor diferente.
17.- Realiza el dibujo de un rectángulo de 80 por 40. Rellenael rectángulo del color que desees.
18.- Realiza el dibujo de un triángulo equilátero de 80 de lado. Cada lado del triángulo debe tener un color diferente.
19.- Realiza el dibujo de un decágono de 20 de lado y rellénalo del color que desees.
20.Abre WinLogo y sitúate en la ventana de trabajo. Escribe las siguientes líneas:
• Repite 4[av 60 gd 90]
• Bp
• REPITE 6 [AV 40 GD 60]21.- Realiza el dibujo de un triángulo de 60 de lado.
22.- Realiza el dibujo de un hexágono de 50 de lado.
23.- Realiza el dibujo de un polígono de 20 lados y 30 pasos cada lado.
24.- Realiza el dibujo de un polígono de 50 lados y 20 pasos cada lado.
25.- Realiza el dibujo de una circunferencia.
26.- Realiza el dibujo de una línea discontinua.
27.- Realiza el dibujo de una escalera de 20 dealto y de largo.
PRIMERA PARTE
28.- En el área de trabajo define el procedimiento CUADRADO escribiendo las siguientes líneas:
• para CUADRADO
• repite 4[av 60 gd 90]
• fin
• CUADRADO
• Bp
29.- Define el procedimiento OCTOGONO que al ejecutarlo dibuje un octógono de 20 de lado.
30.- Define el procedimiento PENTAGONO de manera que al ejecutarlo dibuje un pentágono de 10 delado.
31.- Define el procedimiento ESCALERA de forma que al ejecutarlo dibuje una escalera de 5 peldaños y cada peldaño de 20 por 20.
32.- Define el procedimiento CIRCUNFERENCIA de forma que al ejecutarlo dibuje una circunferencia.
33.- Usando la orden PonPos realiza el dibujo siguiente.
[pic]Debes tener en cuenta que tendrás que avanzar 90 puntos, volver a la posición inicial y despúes...
tracking img