El mejor

Solo disponible en BuenasTareas
  • Páginas : 18 (4495 palabras )
  • Descarga(s) : 4
  • Publicado : 10 de abril de 2010
Leer documento completo
Vista previa del texto
RUBEN
NAVARRO
CASERO
&
RAUL
MORALES
GARCIA

© 2004

Ejercicios de Pseudocódigo Parte 2

1. Leer una secuencia de números y mostrar la suma de los pares y el producto de los que son múltiplo de 5.
2. Leer una secuencia de números y determinar el mayor de los pares leídos.
3. Leer una secuencia de números y mostrar el mayor de los múltiplos de 5 leídos y el menor de losmúltiplos de 3 leídos.
4. Leer una secuencia de letras y mostrar la suma de sus códigos ASCII. Suponemos que tenemos la función Conv_a_Codigo (char)=int.
5. Dado un vector de 5 enteros actualizar cada posición de dicho vector con un número leído.
6. Leer una secuencia de 20 números almacenarlos en un vector y mostrar la posición donde se encuentra el mayor valor leído.
7. Dado dosvectores A y B de 15 elementos cada uno, obtener un vector C donde la posición i se almacene la suma de A[i]+B[i].
8. Dado dos vectores A y B de 15 elementos cada uno, obtener un vector C donde la posición i se almacene la suma de A[i]+B[i] y mostrar el mayor de los C[i].
9. Dado una secuencia de número leídos y almacenados en un vector A mostrar dichos números en orden.
10. Dado unasecuencia de número leídos y almacenados en un vector A y un número leído determinar si dicho número se encuentra o no en el vector.
11. Leer una secuencia de 20 números y almacenar en un vector sus factoriales.
12. Leer 20 números y almacenarlos de manera ordenada en un vector.
13. Dado dos matrices A y B obtener la suma.
14. Dado una matriz determinar la posición (i,j) del mayor.
15.Dado una matriz determinar la posición (i,j) del mayor y menor.
16. Leer un número y una letra si la letra es B mostrar el valor en binario, si es O en octal y si es H en hexadecimal.
17. Leer una secuencia de 20 números almacenarlos en un vector A[1..20] y mostrar la suma de los elementos que ocupan posiciones pares y el mayor de los que ocupan posiciones impares.
18. Dada una matrizA[1..4][1..5] realiza la ordenación de la misma.
19. Dada una matriz A[1..4][1..5] realiza el proceso de ordenar solo por filas.
20. Dado un vector de números determina aquellos que sea primos.
ALGORITMO ejercicio 5
VARIABLE
ENTERO n[1..5];
ENTERO indice;
FIN_VARIABLE
INICIO
PARA indice = 1 HASTA 5 INCREMENTO 1
ESCRIBIR (“Introduce un numero”);
LEER (indice);
FIN_PARAFIN_INICIO
FIN_ALGORITMO

----------------------------------------------------------------------------------------------------------

ALGORITMO ejercicio 6
VARIABLE
ENTERO n[1..20];
ENTERO mayor_indice;
ENTERO indice;
ENTERO mayor;
FIN_VARIABLE
INICIO
PARA indice = 1 HASTA 20 INCREMENTO 1
ESCRIBIR (“Introduce un numero”);
LEER (indice);
FIN_PARA
Mayor = n[1]PARA indice = 1 HASTA 20 INCREMENTO 1
SI (n[indice] > mayor) ENTONCES
Mayor_indice = indice;
FIN_SI
FIN_PARA
ESCRIBIR (mayor_indice);
FIN_INICIO
FIN_ALGORITMO
ALGORITMO ejercicio 7
VARIABLE
ENTERO A[1..15];
ENTERO B[1..15];
ENTERO indice;
ENTERO suma;
ENTERO C[1..15];
FIN_VARIABLE
INICIO
PARA indice = 1 HASTA 15 INCEMENTO 1
ESCRIBIR (“Introduce unnumero para el vector A”);
LEER (A[indice]);
ESCRIBIR (“Introduce un numero para el vector B”);
LEER (B[indice]);
FIN_PARA
PARA indice = 1 HASTA 15 INCREMENTO 1
Suma = A[indice] + B[indice];
C[indice] = suma;
FIN_PARA
PARA indice = 1 HASTA 15 INCREMENTO 1
ESCRIBIR (C[indice]);
FIN_PARA
FIN_INICIO
FIN_ALGORITMO
ALGORITMO ejercicio 8
VARIABLE
ENTEROA[1..15];
ENTERO B[1..15];
ENTERO C[1..15];
ENTERO indice;
ENTERO suma;
ENTERO mayor;
ENTERO mayor_indice;
FIN_VARIABLE
INICIO
PARA indice = 1 HASTA 15 INCRMENTO 1
ESCRIBIR (“Introduce un numero para el vector A”);
LEER (A[indice]);
FIN_PARA
PARA indice = 1 HASTA 15 INCRMENTO 1
ESCRIBIR (“Introduce un numero para el vector B”);
LEER (B[indice]);
FIN_PARA...
tracking img