Estructura de control alternativa multiple

Solo disponible en BuenasTareas
  • Páginas : 2 (344 palabras )
  • Descarga(s) : 0
  • Publicado : 3 de abril de 2010
Leer documento completo
Vista previa del texto
Introducción a la programación.

Alumno. Julio Vázquez.
Universidad de Guadalajara.
CUCEI, IRSI, Febrero 2009.

Estructura de control alternativa multiple.

También conocida como :

Segúnsea, caso de.

Case.

Funcionamiento.

La estructura de decisión múltiple evalúa una expresión que puede tomar n valores distintos, según sea elegido uno de estos valores en la condición, serealizara una de las n posibles acciones.

Aunque este problema se puede resolver con varios “si” es mas eficiente utilizar un case.

Algoritmo.

según sea (selector) hacer   caso1
sentencia1caso2,..:  
sentencia2
   caso n
sentencian … otros...
  sentencia opcional fin_según

Algoritmo.

switch expresion
case valor1
instrucciones1
case valor2
instrucciones2case {valor3, valor4, valor5}
instrucciones3
case …

otherwise
instrucciones4
end

Ejemplo.

según sea (nota) hacer
100..60: escribir ("aprobado")  59..30: escribir("reprobado")  29..0: escribir ("deficiente")

Fin Según

Ejemplo.

switch (nota)

case 100..60:
escribir ("aprobado") case 59..30:
escribir ("reprobado") case 29..0:
escribir("deficiente")

end

Ejercicio.

Escribir un algoritmo que lea un numero entre 1 y 7 y diga a que día de la semana pertenece.

1= Lunes.
2=Martes.

… Etc.
Estructuras Selectivas Anidadas.Hasta ahora las estructuras vistas (simples y doble) solo nos permiten tomar una o dos decisiones, aunque la estructura múltiple ayuda a elegir varias, opciones no siempre es la adecuada para todas lasaplicaciones.

Supongamos que tenemos 3 números introducidos de forma individual a través del teclado, y queremos ver cual de ellos es el mayor.

Como cada numero tiene un valor distinto ydesconocido no es posible utilizar la sentencia case.
El algoritmo que entonces debemos utilizar es el siguiente:

si entonces
si entonces

...
...

fin_si

fin_si...
tracking img