Estructuras condicionales-c++

Solo disponible en BuenasTareas
  • Páginas : 6 (1459 palabras )
  • Descarga(s) : 0
  • Publicado : 25 de noviembre de 2010
Leer documento completo
Vista previa del texto
Una estructura es una colección de variables que están referenciadas bajo un nombre. El C utiliza estructuras para proporcionar unos medios convenientes de mantener en un sitio la información que está relacionada . Una definición de estructura forma una plantilla que se puede utilizar para crear estructuras de variables . Cada estructura esta formada por una o mas variables que estan relacionadaslogicamente. Estas variables se denominan elementos de la estructura. Las estructuras,como grupos de variables conectados lógicamente, se pueden pasar fácilmente a funciones. La utilización de estructuras también puede ser que sea mucho mas fácil de leer el código fuente debido a que la conexión lógica entre los elementos de la estructura es obvia. Una estructura es selectiva cuando solo uno delos procesos alternativos(acciones o funciones) posibles se puede seleccionar tras el cumplimiento de alguna condición determinada. La elección entre varioas alternativas exige una toma de decisiones, por ello a veces las estructuras selectivas se les conoce como de alternativa simple, doble, compuesta y multiple según el número de opciones o alternativas que se pueden tomar. Los puntos donde sedeben tomar las decisiones se denomina punto de decisión y en los diagramas de flujo se representa con el símbolo “rombo”, de modo que uno de los vértices se conecta con el proceso anterior y el otro u otros con el resto de los procesos o acciones. Las estructuras selectivas se clasifican en: a) Simples ESTRUCTURAS SELECTIVAS SIMPLES. Se identifican porque están compuestos únicamente de unacondición. La estructura si - entonces evalúa la condición y en tal caso: Si la condición es verdadera, entonces ejecuta la acción Si (o acciones si son varias). Si la condición es falsa, entonces no se hace nada. Español Si Entonces fin_si Inglés If then endif

Ejemplo 1. Construir un algoritmo tal, que dado como dato la calificación de un alumno en un examen, escriba "Aprobado" en caso que esacalificación fuese mayor que 8. Salidas: mensaje de aprobado si se cumple la condición. Entradas: calificación Datos adicionales: un alumno aprueba si la calificación es mayor que 8 Variables: Cal = calificación Algoritmo: Inicio Leer (cal) Si cal > 8 entonces Escribir ("aprobado") Fin_si Fin

b) Dobles

Son estructuras lógicas que permiten controlar la ejecución de varias acciones y se utilizancuando se tienen dos opciones de acción, por la naturaleza de estas se debe ejecutar una o la otra, pero no ambas a la vez, es decir, son mutuamente excluyentes. Representación pseudocodificada. Español Inglés Si entonces If then sino else Fin_Si End_if Entonces, si una condición C es verdadera, se ejecuta la acción S1 y si es falsa, se ejecuta la acción S2.

Ejemplo 1 Dado como dato lacalificación de un alumno en un examen, escriba "aprobado" si su calificación es mayor que 8 y "Reprobado" en caso contrario. Algoritmo: Inicio Leer (cal) Si cal > 8 entonces Escribir ("aprobado") Sino Escribir ("reprobado") Fin_si Fin

jemplo 2. Dado como dato el sueldo de un trabajador, aplicar un aumento del 15% si su sueldo es inferior a $1000 y 12% en caso contrario, luego imprimir el nuevosueldo del trabajador.

EXPRESIONES LÓGICAS Sirven para plantear condiciones o comparaciones y dan como resultado un valor booleano verdadero o falso, es decir, se cumple o no se cumple la condición. Se pueden clasificar en simples y complejas. Las simples son las que usan operadores relacionales y las complejas las que usan operadores lógicos. Ejemplos: Un ejemplo en el cual usamos el operadorlógico AND sería: Una escuela aplica dos exámenes a sus aspirantes, por lo que cada uno de ellos obtiene dos calificaciones

denotadas como C1 y C2. El aspirante que obtenga calificaciones mayores que 80 en ambos exámenes es aceptado; en caso contrario es rechazado. En este ejemplo se dan las condiciones siguientes: Si (C1 >= 80) y (C2 >= 80) entonces Escribir ("aceptado") Sino Escribir...
tracking img