Funcion excel

Solo disponible en BuenasTareas
  • Páginas : 5 (1103 palabras )
  • Descarga(s) : 0
  • Publicado : 14 de marzo de 2012
Leer documento completo
Vista previa del texto
1. La función SI CONDICIONAL “IF”
La función =SI( ) es una de las más potentes que tiene Excel. Esta función comprueba si se cumple una condición. Si ésta se cumple, da como resultado VERDADERO. Si la condición no se cumple, da como resultado FALSO. Observa la sintaxis:
=SI(Condición;Verdadero;Falso)
Esta es la forma más simple de representar esta función. Vamos a proponer un ejemplo:
Ejemplo1: Se desea aplicar una función a Excel para que diga si una persona es mayor o menor de edad.
[pic]
En la celda C2 se ingresa la función utilizando el botón de Fx, en el campo de Prueba Lógica va la condición que se debe cumplir, o lo que se desea preguntar, en el campo Valor si Verdadero va lo que Excel debe hacer si la condición es verdadera y en Valor si Falso va lo que Excel debe hacer sies caso contrario.
Al cambiar el dato de la celda A2 vemos que la celda de la función se actualiza:
[pic]
Ejemplo 2: Observa el gráfico. Vamos a colocar una función =SI( ) en la celda B4 (celda rosa del descuento).
[pic]
Vamos a hacer que la factura del ejemplo anterior nos haga un descuento del 10% sólo en el caso de cobrar al contado. La fórmula se colocará en la celda B4 y será lasiguiente:
=SI(C1="Contado";B3*10%;0) Nota: la función también se puede ingresar de forma manual.
Esta fórmula mirará si en la casilla C1 (celda amarilla) existe la palabra Contado. En  tal caso, ejecutará una fórmula (10% de descuento), en caso contrario, colocará simplemente un cero en la celda B4, es decir, no realizará ningún cálculo. Observa el resultado:
[pic]



2. FUNCION SI COMPUESTA OANIDADA

Se utiliza cuando el problema es de más de 2 condiciones.

Ej: en una video tienda les dan el precio de alquiler a las películas dependiendo del formato, así: DVD original = 4000$, DVD copia =2500$ y si es VHS= 1000$

Se necesita realizar una aplicación en Excel que escriba el precio de alquiler de las películas de forma automática dependiendo de su formato:

|Películas|Formato |Precio |
|Rambo |VHS | |
|Bambi |Original | |
|El señor de los anillos, la |Original | |
|comunidad del anillo | | |
|Spiderman 3 |Original| |
|La era de hielo 3 |Copia | |
|Transformers 2 |Copia | |
|El silencio de los inocentes |VHS | |


En la primera celda de la columna precio va la siguiente fórmula:

[pic]

La primera condición se puede escribir en la prueba lógica, B2=”Original”,la condición no es cierta, ya que en este momento B2 es VHS, pero es uno de los 3 posibles estados de la celda B2, y puedes partir de cualquiera de ellos, por ejemplo, puedes decir que B2=”Copia”, eso si, en el valor si verdadero de la función debemos ser específicos, si B2 es igual a “Original”, entonces pondrá un valor de 4000.

En el valor si falso van el resto de condiciones, pero debemosescribir el SI de forma manual.

Si B2 es igual a copia, entonces escriba 2500, de lo contrario escriba 1000, ese es el significado de la línea del valor si falso.

Si el ejercicio llegara a tener más de 3 condiciones, cada condición adicional iría en el último espacio del valor si falso con su respectivo SI.

[pic]



Ejercicio: Vamos a hacer el mismo ejercicio anterior, solo quecambiando el planteamiento, clasificar el formato de la película dependiendo del precio.

|Películas |Precio |Formato |




3, FUNCIÓN SI CON CONECTORES LÓGICOS Y, O

Se utilizan cuando las condiciones poseen un rango determinado, por ejemplo, de 3 a 5, entre 5000 y 1000, etc.

Conector lógico Y: es excluyente, la respuesta es verdadera cuando...
tracking img