Funciones excel

Solo disponible en BuenasTareas
  • Páginas : 5 (1166 palabras )
  • Descarga(s) : 0
  • Publicado : 29 de mayo de 2011
Leer documento completo
Vista previa del texto
Definición Una función es una fórmula ya preparada por Excel, que permite ahorrar tiempo y cálculos, y que produce un resultado. Por ejemplo, imaginemos que tenemos que sumar una columna de datos numéricos:

'Funciones'

En el ejemplo de la izquierda podríamos colocar en la celda A10 la fórmula: =A3+A4+A5+A6+A7+A8, pero esto mismo resultaría horrible si en lugar de 5 celdas hubiese que sumar100.

En lugar de esa fórmula, utilizamos la función =SUMA(A3:A8) que realizará exactamente la misma operación; sumar el rango de celdas A3:A8.

Las funciones aceptan unos valores (en este caso el rango de celdas) llamados argumentos.

Sintaxis Observa la sintaxis de una función:

'Funciones'

Las funciones las podemos introducir de dos formas:

Mediante teclado.

Mediante elasistente para funciones.

La función =SI( )

Definición y sintaxis La función =SI( ) es una de las más potentes que tiene Excel. Esta función comprueba si se cumple una condición. Si ésta se cumple, da como resultado VERDADERO. Si la condición no se cumple, da como resultado FALSO. Obseva la sintaxis:

=SI(Condición;Verdadero;Falso)

Esta es la forma más simple de representar esta función,porque la misma se puede complicar que no veas. De momento vamos a proponer un ejemplo:

Observa la hoja de la derecha. Se trata del último ejemplo de la lección anterior. Observa que hemos añadido nuevas celdas y hemos modificado algunas. Ahora se trata de colocar una función =SI( ) en la celda E15 (celda rosa del descuento). 'Funciones'

Ejemplo Vamos a hacer que la factura del ejemploanterior nos haga un descuento del 10% sólo en el caso de cobrar al contado. La fórmula se colocará en la celda E15 y será la siguiente:

=SI(A17="Contado";E14*10%;0;)

Esta fórmula mirará si en la casilla A17 (celda amarilla) existe la palabra Contado. En tal caso, ejecutará una fórmula (10% de descuento), en caso contrario, colocará simplemente un cero en la celda E15, es decir, no realizaráningún cálculo. Observa el resultado:

'Funciones'

En el siguiente ejemplo vamos a ver una variación de la función =SI

En el ejemplo anterior vimos que la función =SI debía cumplir una condición, que era la de controlar si en una celda determinada había un texto. Pero, ¿qué pasaría si se

'Funciones'

Tuviesen que cumplir más de una condición? Supongamos que la función =SI debe teneren cuenta dos condiciones. Estas dos condiciones podrían ser:

Que la función =SI hiciese algo sólo si se tuvieran que cumplir las dos

Que la función =SI hiciese algo si se cumpliese una de las dos

Controlaremos una u otra forma con dos operadores lógicos: el Y y el O

La sintaxis de la orden sería la siguiente

=SI(Y(Condición1:Condición2............ Caso en el que se debancumplir todas las condiciones

=SI(O(Condición1:Condición2............ Caso que se deba cumplir sólo una

En el siguiente ejemplo hemos diseñado una hoja de control de flujo de caja en un hipotético caso en el que debamos controlar entradas y salidas además del saldo.


En las columnas C y D introduciremos las cantidades según sea un gasto (extracción) o un ingreso (depósito). Seríamuy fácil colocar en la celda E5 (saldo) la siguiente fórmula: =E4+C5-D4, que calcularía el saldo anterior, más la cantidad de la celda del depósito, menos la cantidad de la celda de la extracción. El problema viene cuando copiamos la fórmula varias celdas hacia abajo. A partir de la celda del último saldo, siempre nos mostraría el saldo anterior, hubiésemos o no, introducido cantidades en lasceldas de depósito o extracción.

Observa el resultado que se obtendría:

'Funciones'

Evidentemente, no queda muy estético a la vista. En la ilustración superior utilizamos la función =SI, la cual ha de controlar que se cumplan dos condiciones: que introduzcamos una cantidad en la celda del depósito o de la extracción. Sólo en uno de los dos casos se ejecutará la función. De esa forma, si...
tracking img