Hola

Solo disponible en BuenasTareas
  • Páginas : 3 (733 palabras )
  • Descarga(s) : 0
  • Publicado : 3 de septiembre de 2010
Leer documento completo
Vista previa del texto
1. Escribir una función tal que dada la temperatura máxima del mes y la temperatura medida hoy, actualice el valor de la máxima si la temperatura leída hoy es mayor que dicho máximo.

Nombre de lasVariables:
TTM: Temperatura máxima del mes
TH: Temperatura hoy

PSEUDOCÓDIGO

Variables
Real: TMM, TH
INICIO
Leer TMM
Si (TMMgv)
Escribir ´Local´
Si_no
Si (gl= 1) y (Pos4) y (Pos 6) y (Pos 8) entonces
Escribir ("aprobado")
Sino
Escribir ("desaprobado")
Fin_si
Fin

5. Dado como dato el sueldo de un trabajador, aplicar un aumento del15% si su sueldo es inferior a $1000 y 12% en caso contrario, luego imprimir el nuevo sueldo del trabajador. (http://www.mailxmail.com/curso-aprende-programar/estructura-seleccion-doble)PSEUDOCÓDIGO
INICIO
Leer S
Si (S b)
Escribir a, ‘es mayor que ’, b
Sino
Escribir ‘Los 2 números son iguales’
Fin_si
Fin_si
FIN

7. Para calcular el nivel de ruido deuna calle de una cuidad se realizan 4 medidas, una cada 8 horas, en un punto concreto. Si la media de las medidas del nivel de ruido supera la máxima admitida (por ejemplo, MÁXIMA = 4) significa que elruido es nocivo para la salud. Realizar un programa que calcule el nivel de ruido de una calle y determine si el nivel de ruido es nocivo o admisible.

Análisis del problema
La media de lasmedidas del nivel de ruido:[pic]
Nivel máximo de ruido admisible: MAX

PSEUDOCÓDIGO

Variables
Real: media, [pic], [pic], [pic], [pic]
Entero: MAX
INICIO
Leer [pic], [pic], [pic], [pic]
media ←([pic])/ 4
Si (media C)
mayor ← A // A > B, A > C
Si_no
Mayor ← C // C >= A > B
Fin_si
Si_no
Si (B > C)
mayor ← B // B >= A, B > C
Si_no
mayor ← C // C>= B >= A
Fin_si
Fin_si
Escribir ‘Mayor: ’, mayor
FIN

16. Detectar si un número ingresado por teclado tiene o no parte fraccionaria.

PSEUDOCÓDIGO

Variables
Real: N
INICIO
Leer...
tracking img