Laboratorio 1 algoritmos

Solo disponible en BuenasTareas
  • Páginas : 5 (1050 palabras )
  • Descarga(s) : 0
  • Publicado : 19 de noviembre de 2011
Leer documento completo
Vista previa del texto
LABORATORIO 1

JUAN CARLOS GARCÍA MIRANDA

ING. ANTONIO LOPEZ
TUTOR

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA
ESCUELA DE CIENCIAS BÁSICAS, TECNOLÓGICAS E INGENIERÍA
PROGRAMA DE INGENIERÍA DE SISTEMAS
ALGORITMOS
CEAD VALLEDUPAR
NOVIEMBRE DE 2011

TALLER PROPUESTO

1. Determinar cuál es el cuadrado, de un determinado número

2. Elaborar un diagrama de flujo que permitadeterminar si un número es Positivo o Negativo

3. Ejercicio de conversión, desarrollar un diagrama, que perita ingresar una cantidad en metros y la convierta a Centímetros, Kilómetros, Pies, pulgadas..

4. Leer una determinada temperatura en grados centígrados y convertirla a Fahrenheit

5. una persona es apta para prestar el servicio militar obligatorio (presente), cuando: esmayor de 18 años, menor de 25 años, nacionalidad Colombiana y género masculino. Realizar un diagrama que permita determinar si una persona es apta o no par prestar el servicio militar

6. Elabore un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el área total y el volumen del cilindro

7. Una persona recibe un préstamo de un banco por un añoy desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1.8% mensual. Realice un diagrama de flujo que permita determinar este monto

8. Elaborar un diagrama de flujo, que permita ingresar 3 valores y los imprima en forma descendente

9. Una empresa ha decidido, realizar aumentos de salario a sus trabajadores de acuerdo a lassiguientes categorías

Sindicalizado 20%
De confianza 10%
Alto directivo 5%
Ejecutivo 0%

1-

Proceso Cuadrado
Escribir "Ingrese un numero";
Leer numero;
cuadrado<-numero*numero;
Escribir "El cuadrado de ", numero, " es ", cuadrado;
FinProceso

2-

Proceso numero_positivo_o_negativo
Escribir "Digite un numero diferente de cero";
Leer numero;
Si numero=0Entonces
Escribir "Digite otro numero diferente de cero";
Sino
Si numero>=1 Entonces
Escribir "El numero ",numero, " es positivo";
Sino
Escribir "El numero ",numero, " es negativo";
FinSi
FinSi
FinProceso

3-

Proceso metros
Escribir "ingrese la cantidad de metros a convertir";
Leer metros;
Kilómetros<-metros/1000;
Pies<-Metros/328;Pulgada<-metros/39.37;
centímetros<-metros*100;
Escribir metros," metros es igual a ",Kilómetros," kilómetros"
Escribir metros," metros es igual a ",Pies," Pies";
Escribir metros," metros es igual a ",pulgada," pulgadas";
Escribir metros," metros es igual a ",centímetros," centímetros";
FinProceso

4-
Proceso Temperaturas
Escribir "digite la temperatura en grados centígrados aconvertir";
Leer temperatura;
f<-(temperatura*9/5)+32;
Escribir temperatura, " grados centígrados es igual a ",f, " grados Fahrenheit";
FinProceso

5-

Proceso militar
Escribir "Datos del aspirante";
Escribir "ingrese edad del aspirante";
Leer edad;
Escribir "ingrese la nacionalidad el aspirante, escriba 1(uno)si es de nacionalidad colombiana, sino escriba otro numerodiferente";
Leer nacionalidad;
Escribir "ingrese el sexo el aspirante, escriba 1 (uno) si es masculino, sino escriba otro numero";
Leer sexo;

Si edad>=18 Y edad<=25 Entonces
Escribir "el aspirante es apto";
Sino
Escribir "el aspirante no es apto";
FinSi
Si nacionalidad=1 Entonces
Escribir "el aspirante es apto";
Sino
Escribir "el aspirante no es apto"
FinSi
Sisexo=1 Entonces
Escribir "el aspirante es apto"
Sino
Escribir "el aspirante no es apto"
FinSi
Escribir "Presione enter para continuar"
Leer espacio
Si edad>=18 Y edad<=25 Y nacionalidad=1 y sexo=1 Entonces
Escribir "EL ASPIRANTE ES APTO"
Sino
Escribir "EL ASPIRANTE NO ES APTO"
FinSi
FinProceso
6-

Proceso cilindro
Escribir "ingrese radio del cilindro...
tracking img