Mi primer algoritmo

Solo disponible en BuenasTareas
  • Páginas : 3 (664 palabras )
  • Descarga(s) : 0
  • Publicado : 18 de febrero de 2011
Leer documento completo
Vista previa del texto
ALGORITMO CREACIONDIRECTO PROCESO DE ARCHIVO DIRECTO

INICIO
REGISTRO REMP

ENTERO Num

CADENA[30]Nomb

ENTERO Dpto

ENTERO Puesto

REAL Sueldo

FIN REGISTROARCHIVO DE REMP AEMP

Entero i, NumReg

1. CREAR AEMP, directo

2. LEER NumReg // Numero de registros que tendra el archivo

3. REMP.Num = 0 ,REMP.Nomb= ‘ ’,REMP.Dpto=0, REMP.Puesto = 0, REMP.Sueldo= 0,

4. PARA i ß 1 HASTA i ß NumReg

IMPRIMIR (AEMP. REMP) // se graba el registro con ceros y nulos

FIN PARA

5. REMP.Nombre ß‘FIN’ // se coloca FIN al nombre

6. IMPRIMIR (AEMP. REMP) // se graba el ultimo registro como centinela

7. CERRAR AEMP // se cierra elarchivo AEMP

FIN



ALGORITMO ALTAS
INICIO

REGISTRO REMP

ENTERO Num

CADENA[30] NombENTERO Dpto

ENTERO Puesto

REAL Sueldo

FIN REGISTRO

ARCHIVO DE REMPAEMP

CARÁCTER Desea

1. ABRIR AEMP, Directo

2. REPETIR

LEER REMP.Num, REMP.Nomb, REMP.Dpto, REMP.Puesto, REMP.Sueldo,

ENCONTRAR (AEMP, REMP.Num) // se colocael puntero en la posicion del numero del

// empleado que se almacenara

IMPRIMIR (AEMP, REMP) // se graba el registro

LEER Desea

HASTA Desea = ‘N’

3.CERRAR AEMP

FIN



ALGORITMO BAJAS
INICIO

REGISTRO REMP

ENTERO Num

CADENA[30] Nomb...
tracking img