No fue la suerte

Solo disponible en BuenasTareas
  • Páginas : 2 (437 palabras )
  • Descarga(s) : 0
  • Publicado : 9 de mayo de 2010
Leer documento completo
Vista previa del texto
ESTRUCTURAS DE CONTROL Se conocen con este nombre a las estructuras algorítmicas que permiten romper el control secuencial del algoritmo y hacer unos pequeños saltos entre instrucciones. Existen dostipos de estructuras de control, las estructuras de selección y las estructuras repetitivas. Estructuras de selección: Estas estructuras permiten evaluar una condición y dependiendo del resultado dedicha evaluación, el control se pasa a otro lado del algoritmo. Existen dos tipos de estructuras de selección, las simples y las compuestas. Estructuras de selección simples La estructura de selecciónsimple se conoce como SI_ENTONCES. Esta estructura, dependiendo de la condición que se evalúa puede hacer una acción, en caso de que la evaluación sea verdadera y puede también hacer una acción encaso de que la evaluación sea falsa. Versión 1 Si condición entonces Acción en caso verdadero Fin_si Versión 2 Si condición entonces Acción en caso verdadero Sino Acción en caso falso Fin_si

Tiene dosversiones, por que no siempre es obligatoria la acción en caso de que la condición se evalué como falsa. Por ejemplo, si quisiéramos saber cual de dos números es el mayor, se podría usar el siguientealgoritmo: Algoritmo mayor Var a,b:entero Inicio Leer(a,b) Si a>b entonces Escribir(“El numero mayor es “, a) Sino Escribir(“El numero mayor es “, b) Fin_si Fin Para el anterior algoritmo,encontramos que la condición que queremos evaluar, implica una comparación relacional entre las variables a y b, que nos indique cual es mayor que la otra, lo que implica que la condición en la estructura si,debe ser una expresión relacional. (Esta puede combinarse con expresiones lógicas)

Algoritmo mayor_o_igual Var a,b:entero Inicio Leer(a,b) Si a>b ó a=b entonces Escribir(“El numero mayor o igual es“, a) Sino Escribir(“El numero mayor es “, b) Fin_si Fin Vale la pena anotar que para este ejemplo, se puede usar simplemente el operador mayor o igual (>=). Anidamiento de estructura SI Existen...
tracking img