Parcialsolucionado

Solo disponible en BuenasTareas
  • Páginas : 3 (649 palabras )
  • Descarga(s) : 11
  • Publicado : 28 de junio de 2010
Leer documento completo
Vista previa del texto
Solución del primer Parcial efectuado en Marzo 30-2009 UNIVERSIDAD NACIONAL DE COLOMBIA SEDE DE MEDELLÍN ___________________________________ FACULTAD NACIONAL DE MINAS Escuela de Sistemas Fundamentosde programación - Primer examen parcial

TEMA A

1 Diseñe un algoritmo (en pseudocódigo, diagrama de caja, diagrama de flujo o directamente en VBA) para leer las variables correspondientes yevaluar la siguiente fórmula:

( P + Q) R El algoritmo debe decir si el resultado es real o no. En caso afirmativo debe mostrarlo y decir si es positivo, negativo o nulo. En caso de ser positivo debedecir adicionalmente si es menor que 10. Por ejemplo, si los valores de P, Q, y R son 8, -5 y 4 respectivamente, lo que debería mostrar es: Positivo Menor que 10
Solución: Una solución posible es:INICIO Leer P, Q, R Si (R < 0) Mostrar “No es real” De lo contrario Mostrar “Es real” T = ( P + Q) R Mostrar T Si (T > 0) Mostrar “Positivo” Si (T < 10) Mostrar “Menor que 10” Fin Si De lo contrario Si(T < 0) Mostrar “Negativo” De lo contrario Mostrar “Nulo” Fin Si Fin Si FIN



«3007742 – Fundamentos de programación»

Solución del primer Parcial efectuado en Marzo 30-2009
2 Dada lasiguiente serie, diseñe un algoritmo (en pseudocódigo, diagrama de caja, diagrama de flujo o directamente en VBA) para que muestre los primeros 10 términos exceptuando el séptimo, y la productoria de lostérminos 11 a 20.

2 4 6 8 10 , , , , , ... 2 4 6 8 5 X 5 X 5 X 5 X 5 X 10
Solución:

Una solución posible es: INICIO Leer X P=1 Para i=1, 100) Mostrar “Mayor que 100” De lo contrario Si (T <100) Mostrar “Menor que 100” Si (T < 0) Mostrar “Negativo” Fin Si De lo contrario Mostrar “Igual a 100” Fin Si Fin Si FIN
2 Dada la siguiente serie, diseñe un algoritmo (en pseudocódigo, diagrama decaja, diagrama de flujo o directamente en VBA) para que muestre los primeros n términos. Adicionalmente debe mostrar cual es el promedio de los negativos y cual el de los positivos.

cos( x) cos( x)...
tracking img