Practica error relativo esime ipn

Solo disponible en BuenasTareas
  • Páginas : 5 (1099 palabras )
  • Descarga(s) : 0
  • Publicado : 11 de septiembre de 2012
Leer documento completo
Vista previa del texto
Instituto Politécnico Nacional

Escuela Superior de Ingeniería Mecánica y Eléctrica

Ing. Control y Automatización

Análisis Numérico

Cesar Morales Flores

3AM6

Practica 1: “Calculo del Error”

Introducción.
En los métodos numéricos el valor verdadero solo se conocerá cuando se tengan funciones que se resuelvan analíticamente .Este comúnmente será el caso cuando se estudie seestudie el comportamiento teórico de una técnica especifica para sistemas simples. Sin embargo, en muchas aplicaciones reales, no se conoce a priori la respuesta verdadera.
Entonces en dichos casos, una alternativa es normalizar el error, usando la mejor estimación posible al valor verdadero; es decir para la aproximación misma como en.
εa=error aproximadovalor aproximado 100%
Donde el subíndice“a” significa que el error esta normalizado a un valor aproximado.
Uno de los retos que enfrentan los métodos numéricos es el de determinar estimaciones de error en ausencia del conocimiento de los valores verdaderos; el error a menudo se calcula como la diferencia entre la aproximación previa y la actual. Por lo tanto, el error relativo porcentual esta dado por.
εa=aproximacionactual-aproximacion anterioraproximacion actual 100%
Normalizado a un valor aproximado.
Los valores de la ecuación pueden ser negativos o positivos. Si la aproximación es mayor que el valor verdadero el error es negativo, si la aproximación es menor que el valor verdadero, el error es positivo. Lo importante es que su valor absoluto porcentual sea menor que una tolerancia porcentual prefijada.
εa=|aproximacionactual-aproximacion anterioraproximacion actual |100%

Desarrollo.
Diagrama UML

error |
* v[10] :int * total: int * P[10] : int * I : int |
+ error( ) + pot(int,int): int + calc_promedio():int +calc_error:float + fillpot():int + imp_tab():void |



Algoritmo
Para la realización de este programa, usamos una serie de formulas para calcular el errorporcentual, por lo que no se considera como un algoritmo formal; si no mas bien, una seria de pasos para obtener un resultado deseado.
La primera de ellas es la formula de watt para calcular la potencia de un elemento en un circuito de CD.
P=I*V
La segunda es la utilizada en estadística para encontrar una media entre un numero de resultados determinado en este caso el promedio de las potencias.Prom=elementosnumero de elementos
Y la ultima la usada para calcular el error porcentual.
εa=|aproximacion actual-aproximacion anterioraproximacion actual |100%

Pseudocodigo.
Inicio del programa
INICIO CLACE ERROR
Entorno V[11],P[11],I Enteros
CREACION DE FUNCIONES
error();
int pot(int,int);
int calc_promedio();
float calc_error();
voidimp_tab();
int fillpot();
FIN CLACE ERROR
INICIO FUNCION ERROR
Inicia la corriente en 12 amp
Para (j desde 1 hasta 11 incrementa en 1)
Escribir “Tension” valor de j
Ingresar valor en V[valor de j]
FIN PARA
FIN FUNCION ERROR

INICIO FUNCION POT
Regresar Producto de parámetros X y Y;
FIN FUNCION POT

INICIO FUNCION CALC_PROMEDIO
Entorno suma entera inicializada en 0Para(j desde 1 asta 11 incremento en 1)
Suma=suma + P[valor de j]
FIN PARA
Regresar suma dividido entre 11
FIN FUNCION CALC_PROMEDIO
INCIO FUNCION CALC_ERROR
Entorno x,y,z flotantes
Asigna x LLAMAR A FUNCION CALC_PROMEDIO
Asigna y Valor de P[posición 1]
z=((y-x)/y)*100
CONDICION z>0
Afirmativa
Regresar z
Negativa
Regresar z*(-1)
FIN FUNCION CALC_ERROR

INICIO FUNCION FILLPOTPara(j desde 1 hasta 11 incremento en 1)
P[valor de j]=Llamara a función pot(V[valor de j],I)
FIN PARA
Regresar 1
FIN FUNCION FILL POT
INICIO PROCEDIMEINTO IMP_TAB
Escribir “Corriente constante (tabular) “ Valor de I “amp” “salto de línea doble”
Escribir “Voltaje””Potencia”
Para(j desde 1 hasta 11 incremento en 1)
Escribir “V” valor de j “=” V[valor de j] “volts”
Escribir “P”...
tracking img