Primeratarea

Solo disponible en BuenasTareas
  • Páginas : 8 (1881 palabras )
  • Descarga(s) : 0
  • Publicado : 13 de mayo de 2011
Leer documento completo
Vista previa del texto
ALGORITMICA 
Programación Estructurada Programación Estructurada 
Fundamentos III: Estructuras Selectivas  (Simples, Dobles, Multiples) 

Expositor : Jorge Medianero A. 
Autor: José Carlos, García La Riva 

Estructuras Condicionales 
Las estructuras condicionales, me  permiten evaluar una expresión o  expresiones y según el resultado de esta  evaluación se procesan un grupo de instrucciones y/o sentencias.  Las estructuras condicionales se clasifican  a su vez en : 
Estructuras Selectivas  Estructuras Repetitivas Estructuras Repetitivas 

Estructuras Selectivas 
Las estructuras selectivas permiten evaluar una expresión  o expresiones para luego procesar un grupo de  instrucciones y/o sentencias. Estas estructuras se  instrucciones y/o sentencias. Estas estructuras se procesan solo 1 vez.  procesan solo 1 vez  .  Las estructuras selectivas se clasifican en : 
Condicional Simple (si /  Condicional Simple (  fin_si)  si / fin_si  si /  )  Condicional Doble (si / si_no / fin_si)  Condicional Doble (  si_no / fin_si  si / si_no  )  Condicional Anidada (si_no  Condicional Anidada (  si_no/si, Similar a Condicional Doble  si_no  /si, Similar a Condicional Doble)  ) Condicional Múltiple (segun_sea / fin_segun  o tambien  Condicional Múltiple (  segun_sea /  segun_sea  fin_segun)  tambien  ) o  (caso_de / fin_caso  (  caso_de /  caso_de  fin_caso)  )

2.1. Condicional Simple 
Se emplea para evaluar una expresión o  expresiones, si  el resultado de esta evaluación  es un valor lógico verdadero (true  es un valor lógico verdadero (  ), entonces se true), entonces se  procesaran un grupo de instrucciones o  sentencias.  Sintaxis :  SI ( Expresion )  SI ( Expresion ) ENTONCES  ( Expresion ) ENTONCES  Instrucciones  :  true true  y / o  Sentencias  :  FIN­  FIN  SI  ­SI 

Problema 1: Ingrese 2 números enteros y visualice  el mayor de los 2 números ingresados. 
Algoritmo Numero mayor  Algoritmo Numero mayor  var  entero:  a, b, mayor a, b, mayor INICIO  leer( a, b)  leer  ( a, b)  mayor ← a  si( b > a ) entonces  si  ( b > a ) entonces  mayor ← b  fin_si  escribir( mayor )  escribir  ( mayor )  FIN 

Problema 2 : Ingrese un número entero, si es  mayor a 10 súmele 10 unidades y visualice el  nuevo valor. 
Algoritmo Suma condicional  Algoritmo Suma condicional  variables  entero:  n  INICIO  leer( n )  leer  ( n )  si( n > 10) entonces si  ( n > 10) entonces  n ← n + 10 n ← n + 10  fin_si  escribir( n )  escribir  ( n )  FIN 

Problema 3 : Una tienda ofrece un descuento del 3% para un  producto en promoción, si el número de productos adquiridos  excede en 5. Calcular el total a pagar por cada compra. 
Algoritmo Compra con descuento  Algoritmo Compra con descuento  variables  entero:  cantidad  real: precio, Vcompra, descuento, total  constante  valorDesc = 0.03  INICIO  leer( cantidad, precio )  leer  ( cantidad, precio )  Vcompra ← cantidad * precio  si ( cantidad > 5 ) entonces  si ( cantidad > 5 ) entonces  descuento ← Vcompra * valorDesc  fin_si  total ← Vcompra – descuento  total ← Vcompra – descuento  descuento escribir( total )  escribir  ( total )  FIN 

Problema 4 : Ingrese un número entero y luego visualice un mensaje indicando si el número  ingresado es “PAR” o “IMPAR”. 
Algoritmo enteros pares e impares  Algoritmo enteros pares e impares  variables variables  entero:  n, resto  INICIO  leer( n )  leer  ( n )  resto ← n MOD 2  resto ← n MOD 2  si ( resto = 0 ) entonces  si ( resto = 0 ) entonces  escribir(“PAR”)  fin_si  si ( resto  0 ) entonces  si ( resto  0 ) entonces  escribir(“IMPAR”)escribir(“IMPAR”)  fin_si  FIN 

Problema 5: Una empresa otorga un bonificación del  5% del haber básico a sus trabajadores que tienen  hijos, calcular el total a pagar por este concepto. 
Algoritmo Bonificacion familiar  Algoritmo Bonificacion familiar  variables  entero:  NroHijos  real:  Hbasico, bonificacion, total  Hbasico  bonificacion  , bonificacion  , total  INICIO  leer(  leer ...
tracking img