Programacion java proyecto

Solo disponible en BuenasTareas
  • Páginas : 6 (1479 palabras )
  • Descarga(s) : 0
  • Publicado : 10 de noviembre de 2011
Leer documento completo
Vista previa del texto
Julián Raymundo Cedillo Cano |
PROYECTO 2do PARCIAL.
|
Metodología de la Programación Java |

Profr. Yadira C.
04/11/2011
|

PROBLEMA.
Escriba un programa que permita calcular lo que hay que pagarle a un numero N (mas de uno) de trabajadores teniendo en cuenta el sueldo y las horas extras trabajadas. Para el pago de horas extras se toma en cuenta la categoría del trabajador.Categoría | Precio Hora Extra |
1 | $30 |
2 | $38 |
3 | $50 |
4 | $70 |

Cada trabajador puede tener como máximo 30 horas extras, si tiene mas solo se le pagaran 30. A los trabajadores con categoría mayor a 4 no debemos pagarles horas extras.
-------------------------------------------------
El programa deberá de mostrar como salida el nombre del trabajador, su sueldo, su categoría y elpago total con o sin horas extras en caso de ser acreedor a horas extras.

DIAGRAMA (ENTRADA-PROCESo-SALIDA).
ENTRADA:
Nombre
Categoría
Sueldo
Horasextra
regresar
PROCESO:
regresar<-"si";
Mientras regresar = "si" Hacer
Escribir "Que tal,¿Cual es su nombre?:";
Leer nombre;
Escribir "Cuanto es su sueldo?:";
Leer sueldo;
Escribir "Menu de Horas extras Trabajadas":Escribir "1. $30";
Escribir "2. $38";
Escribir "3. $50";
Escribir "4. $70"
Escribir "Eliga la Categoria que pertenece";
Leer categoria;
Si categoria >=5 Entonces
Escribir "No pertenece a ninguna categoria";
Sino
Escribir "Cuantas horas extra trabajo"
Leer horase;
FinSi
Si horase >30 Entonces
Escribir "No se pueden pagar hora extra"" Sr.",nombre," Sueldo:$",sueldo, "Categoria:",categoria, " Total:$",sueldo;;
Sino
Si categoria = 1 Entonces
extra<-horase * 30;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;

Sino
Si categoria = 2 Entonces
extra<-horase * 38;
Escribir "Su pago extra es de:", extra;total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;
Sino
Si categoria = 3 Entonces
extra<-horase * 50;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;Sino
Si categoria = 4 Entonces
extra<-horase * 70;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;
Sino
Escribir "Gracias por usar el programa:", " Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",sueldo;
SinoFinSi
FinSi
FinSi
FinSi
FinSi
Escribir "Desea utilizar de nuevo el programa?:", " Sr.", nombre;
Leer regresar;
FinMientras
FinProceso

SALIDA:
“Nombre”.
“Sueldo”
“Categoría”.
“total”.
“Extra”.
Si categoria >=5 Entonces
Escribir "No pertenece a ninguna categoria";
Sino
Escribir "Cuantas horas extra trabajo"
Leer horase;
FinSi
Si horase >30 EntoncesEscribir "No se pueden pagar hora extra"" Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",sueldo;;
Sino
Si categoria = 1 Entonces
extra<-horase * 30;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;
Sino
Si categoria = 2 Entoncesextra<-horase * 38;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:" ,"Sr.",nombre," Sueldo:$",sueldo, " Categoria:",categoria, " Total:$",total;
Sino
Si categoria = 3 Entonces
extra<-horase * 50;
Escribir "Su pago extra es de:", extra;
total<-extra + sueldo;
Escribir "Su pago total es de:"...
tracking img