Programacion

Solo disponible en BuenasTareas
  • Páginas : 2 (303 palabras )
  • Descarga(s) : 0
  • Publicado : 16 de junio de 2011
Leer documento completo
Vista previa del texto
PUCESI
DEBER DE PROGRAMACION
NOMBRE: Lenin Andrango
CARRERA: Ing. Sistemas
Con el siguiente Pseudocódigo, realizar la corrida de escritorio dados los siguientes valores de ingreso:
1, 5, 7, 0,2, 8,-5, 0, 3, 7, 9, 0, 4, 3, 7, 0, 5, 7, 0, 6, 0, 6, 1  
INICIO
  ENTERO Num1, Num2, S, Res
  HACER
    ESCRIBIR "...** MENU **..."
    ESCRIBIR "1. Sumar 2 números"
    ESCRIBIR "2. Restar 2números"
    ESCRIBIR "3. Multiplicar 2 números"
    ESCRIBIR "4. Dividir 2 números"
    ESCRIBIR "5. Factorial de un número"
    ESCRIBIR "6. Terminar Programa"
    LEER S
  
    SEGUN S HACER      CASO 1:
         ESCRIBIR "INGRESE Num1"
         LEER Num1
         ESCRIBIR "INGRESE Num2"
         LEER Num2
         Res = Num1 + Num2
         ESCRIBIR "La Suma es: " + Res
      CASO2:
         ESCRIBIR "INGRESE Num1"
         LEER Num1
         ESCRIBIR "INGRESE Num2"
         LEER Num2
         Res = Num1 - Num2
         ESCRIBIR "La Resta es: " + Res  
      CASO 3:          ESCRIBIR "INGRESE Num1"
         LEER Num1
         ESCRIBIR "INGRESE Num2"
         LEER Num2
         Res = Num1 * Num2
         ESCRIBIR "La Multiplicación es: " + Res
      CASO 4:         ESCRIBIR "INGRESE Num1"
         LEER Num1
         ESCRIBIR "INGRESE Num2"
         LEER Num2
         Res = Num1 / Num2
         ESCRIBIR "La División es: " + Res
       CASO 5:
        ESCRIBIR "INGRESE Num1"
         LEER Num1
         SI Num1 < 0 ENTONCES
            ESCRIBIR "El número es negativo"
         SINO 
            SI Num1 == 0 ENTONCES
               ESCRIBIR "Elfactorial es: 1"
            SINO
                Res = Num1
                MIENTRAS (Num1-1) > 1 HACER
                   Res = Res * (Num-1)
                   Num1 = Num1 -1                     FIN MIENTRAS
                ESCRIBIR "El factorial es: " + Res
            FIN SI   
         FIN SI     
 
      CASO 6:
         ESCRIBIR "Esta seguro de finalizar? 1/0"...
tracking img