Programas

Solo disponible en BuenasTareas
  • Páginas : 3 (671 palabras )
  • Descarga(s) : 0
  • Publicado : 11 de mayo de 2011
Leer documento completo
Vista previa del texto
PROGRAMA:Premio de empleado
MODULO:Principal
VARIABLES: sd,f,r,mt
Inicio
Inserte sueldo diario
Leeer sd
Inserte número de faltas
Leer f
Inserte días de retardos
Leer r
Si f=0 y r=0entonces
Mt=15*sd
Desplegar ‘Tu sueldo es:’,mt
Si f=0 y r=10 entonces
Mt=12*sd
Desplegar ‘Tu sueldo es:’,mt
Si f=0 y r=20 entonces
Mt=10*sd
Desplegar ‘Tu sueldo es:’, mt
Si f=5 y r=0entonces
Mt=5*sd
Desplegar ‘Tu sueldo es:’, mt
Fin_si
Fin

PROGRAMA:colores diferentes de pinturas
MODULO:Principal
VARIABLES: canb,col,mot :enteros
Inicio
Inserte el color de boteLeer col
Inserte cantidad de botes
Leer canb
Si=(col=rojo) entonces
Realizar mot=canb*60
Si=(col=azul) entonces
Realizar mot=canb*100
Si=(col=amarillo) entonces
Realizar mot=canb*50Desplegaar mot
Fin_si
Fin

PROGRAMA:Promedio de un alumno
MODULO:Principal
VARIABLES: c1,c2,c3,c4,c5,prom:enteros
Inicio
Inserte calificación 1
Leer c1
Inserte calificación 2
Leer c2Inserte calificación 3
Leer c3
Inserte calificación 4
Leer c4
Inserte calificación 5
Leer c5
Prom=(c1+c2+c3+c4+c5)/5
Si prom >=9 entonces
Desplegar ‘Tienes beca’
Fin_si
Fin

PROGRAMA:Diade la semana
MODULO:Principal
VARIABLES: numdi
Inicio
Inserte un numero
Leer numdi
Si numdi=1
Desplegar’Lunes’
Si numdi=2
Desplegar’Martes’
Si numdi=3Desplegar’Miercoles’
Si numdi=4
Desplegar’Jueves’
Si numdi=5
Desplegar’Viernes’
Si numdi=6
Desplegar’Sabado’
Si numdi=7
Desplegar’Domingo’
Fin_si
Fin

Pedir un valoren euros y lo conviertes a pesetas (1 euro = 166,386ptas).

PROGRAMAconvertir a euros
MODULO:Principal
VARIABLES: pes,eu

Inicio
“Inserte cantidad en euros”
Leer eur
Realizarpes=eu*166.386
“Los euros que equivalen a pesetas es “pes
Fin

Un departamento de climatología ha realizado recientemente su conversión al sistema métrico. Realizar las siguientes conversiones:
a) Leer...
tracking img