Pseudocodigos. ejemplos

Solo disponible en BuenasTareas
  • Páginas : 4 (897 palabras )
  • Descarga(s) : 0
  • Publicado : 30 de marzo de 2011
Leer documento completo
Vista previa del texto
EJERCICIO I

Desarrollar un programa que lea un número entero y obtenga un digito a partir de la suma de sus dígitos que lo componen. El digito no puede tener más de una cifra.

Inicio
numero,suma, residuo entero
numero=0
escribir("Este programa realiza la suma de los dígitos de un numero entero")
mientras (numero<1)
escribir("Digite un numero: ")
leer(numero)
si (numero<1)entonces
escribir("El numero digitado es incorrecto.”)
escribir(“El numero debe ser mayor que cero ")
fin_si
fin_mientras
mientras(numero>9)
suma=0
mientras(numero>0)
residuo=numero%10suma=suma+residuo
numero=numero/10
fin_mientras
si(suma>9)
numero=suma
si_no
escribir("La suma de los dígitos es: suma”)
fin_si
fin_mientras
fin

EJERCICIOS II

1. Escribir un programaen C que imprima en la pantalla su código, nombre completo, dirección, teléfono y signo del zodiaco.

Inicio
Escribir(“Este programa imprime el código, nombre completo, dirección, teléfono y signodel zodiaco”)
Escribir(“Código: 138715”)
Escribir(“Nombre completo: OSCAR LEONARDO ALVARADO ARIAS”)
Escribir(“Dirección: GUACHETA. CARRERA 4° # 1-10. BARRIO GUALACIA”)
Escribir(“Teléfono: 313863 9168”)
Escribir(“Signo del zodiaco: GEMINIS”)
Fin

2. Escribir un programa en C que lea un número entero e indique si el número leído es positivo, negativo o cero y si es par o impar.Inicio
Numero entero
Residuo entero
Escribir(“Este programa lee un numero entero e indica si el numero es positivo, negativo o cero y si es par o impar”)
Escribir(“Digite un numero”)
Leer(Numero)Si(Numero<0) entonces
Escribir(“El numero es negativo”)
Si no
Si(Numero>0) entonces
Escribir(“El numero es positivo”)
Si no
Si(Numero=0) entonces
Escribir(“El numero es cero”)Fin_si
Fin_si
Fin_si
Residuo=Numero%2
Si(Residuo=0) entonces
Escribir(“El numero es par”)
Si no
Escribir(“El numero es impar”)
Fin_si
Fin

3. Escribir un programa que lea dos...
tracking img