Pseudocodigos en pseint

Solo disponible en BuenasTareas
  • Páginas : 5 (1158 palabras )
  • Descarga(s) : 0
  • Publicado : 20 de junio de 2011
Leer documento completo
Vista previa del texto
1) Se posee un monto de dinero de $120, se gasta en supermercado $49,5 y luego en verdulería 12,10. Mostrar el saldo.

Proceso gasto
saldo<-120-49.5-12.10;
Escribir "Saldo ",saldo;
FinProceso

Usar este ejercicio para resaltar la necesidad de la utilización de las variables, ya que este ejercicio se ajusta únicamente para los valores constantes consignados.

2) Realizar elpseudocódigo para calcular el 15% de un valor constante.

Proceso 15%
cal<-325*.15;
Escribir "El 15% de 325 es ",cal;
FinProceso

3) Modificar el pseudocódigo anterior para que muestre el 15% de un valor ingresado.

Proceso 15%
Escribir "Ingrese un numero";
Leer n;
cal<-n*.15;
Escribir "El 15% de ",n," es ",cal;
FinProceso

4) Calcular el nuevo salario de un obrero siobtuvo un incremento del 25% sobre su salario anterior.

Proceso sueldo_obrero
Escribir “Ingrese el Sueldo”;
Leer sueldo;
Nuevo<-sueldo*.25+sueldo;
Escribir “El nuevo sueldo es: “,nuevo;
FinProceso

5) Calcular el doble de un número ingresado, a ese resultado calcularle el 10% y mostrar ese valor.

Proceso 10%del doble
Escribir "Ingrese un numero";
Leer n
doble<-n*2;por<-doble*.1;
Escribir "El 10% del doble de ",n," es ",por;
FinProceso

6) Informar en pantalla el promedio de cinco números.

Proceso promedio_5
Escribir "Ingrese 5 numeros";
Leer n1,n2,n3,n4,n5;
prom<-(n1+n2+n3+n4+n5)/5
Escribir "Promedio: ",prom;
FinProceso

7) Realizar un algoritmo en el cual se obtenga la siguiente información 2.A + 2.B

Proceso 2.A+2.BEscribir "Ingrese un numero";
Leer A;
Escribir "Ingrese otro numero"
Leer B;
cal<-2*a+2*b;
Escribir "Resultado ",cal;
FinProceso

8) Resuelva un algoritmo que solucione el problema de calcular el área de un triangulo con la fórmula: AREA = BASE x ALTURA / 2.

Proceso Area_Triangulo
Escribir "Ingrese la medida de la Base";
Leer base;
Escribir "Ingrese la medida de laAltura";
Leer altura;
area<-base*altura/2;
Escribir "El area del triangulo es: ",area;
FinProceso

9) Ídem para el área de un círculo (se deberá ingresar la medida del diámetro).

Proceso Area_Circulo
Escribir "Superficie del circulo"
Escribir "Ingrese la medida del Diámetro";
Leer diametro;
radio<-diametro/2;
area<-3.1416*radio*radio;
Escribir "El area del Circuloes: ",area;
FinProceso

10) Calcular el área de un rectángulo conociendo el valor de sus lados.

Proceso Area_Rectangulo
Escribir "Area del Rectangulo"
Escribir "Ingrese la medida del lado Mayor";
Leer base;
Escribir "Ingrese la medida de la Altura";
Leer altura;
area<-base*altura;
Escribir "El area del Rectangulo es: ",area;
FinProceso

11) Conociendo el valor de laentrada al cine, calcule el monto a pagar para una delegación de personas. Recuerde que deberá hacer un descuento del 3% por cantidad.

Proceso Entradas_Cine
Escribir “Ingrese el valor de la entrada”;
Leer entrada;
Escribir “Ingrese la cantidad de personas”
Leer personas;
Total<-personas*entrada;
Pagar<-total-total*.03;
Escribir “Importe a abonar: “, pagar;
FinProceso12) Ingresando la cantidad de un producto y su precio unitario, obtener como resultado el precio final que debe pagar el cliente.

Proceso Total_a_pagar
Escribir "Ingrese nombre del producto"
Leer producto;
Escribir "¿Precio Unitario?";
Leer Precio;
Escribir "¿Cantidad adquirida?";
Leer cantidad;
total<-precio*cantidad;
Escribir "Por su compra de ",cantidad," ",producto,"debera pagar $",total;
FinProceso

13) Suponga que un individuo desea invertir su capital en un banco y desea saber cuánto dinero ganará después de un mes si el banco paga a razón de 2% mensual.

Proceso Inversion
Escribir "Ingrese capital a invertir";
Leer cap_inv;
gan<-cap_inv*0.02;
Escribir "Ganacia a obtener: ",gan;
FinProceso

14) Realizar una aplicación que calcule las...
tracking img