Redes

Solo disponible en BuenasTareas
  • Páginas : 6 (1280 palabras )
  • Descarga(s) : 4
  • Publicado : 20 de julio de 2010
Leer documento completo
Vista previa del texto
Calcular e imprimir los salarios que adeudan a 400 trabajadores. Basados en tasas de 1.5 veces la tasa regular, cuando las horas trabajadas excedan de 40 por semana. Lo datos de entrada son el nombre, las horas trabajadas por semana y el pago por hora.

Inicio
N=0, Ph=0, Ht=0, Sal=0
Hacer para I=0 hasta 400
Leer N,Ph,Ht
Si Ht40
Sal=(Ht-40)*1.5Imprimir N,Ht,Ph
Fin si
Fin

1. Imprimir la tabla de multiplicar del número que el usuario ingrese vía teclado.

Inicio
N=0, M=0
Leer N
Hacer para I=0 hasta 12
M=N*I
Imprimir N”*”I”=”M
Fin para I
Fin

2. Imprimir la tabla del 1 al 12.

Inicio
J=0, I=0, R=0
Hacer pata I=1 hasta 12
Hacer paraJ=1 hasta 12
R=I*J
Imprimir I”*”J”=”R
Fin para J
Fin para I
Fin

3. Haga un pseudocódigo que lea un arreglo unidimensional denominado ventas de 50 elementos.

Inicio
Ventas [50]
Hacer para I=1 hasta 50
Leer Ventas[I]
Fin para I
Fin

4. Lea un arreglo de 100 elementos que contiene las matriculas pagadas por losestudiantes de la escuela de ciencia. Determine cuantos pagaron matriculas superiores a los 50 dólares y el promedio de los que pagaron una inferior igual a 50.

Inicio
Mat[100], X=0, Ma=0, Y=0, Me=0
Hacer para I=1 hasta 100
Leer Mat[I]
Si Mat[I]>50
X=X+1
Ma=Mat[I]
Sino
Y=Y+1
M=Me+Mat[I]
Fin si
Fin para IProm=Ma/Y
Imprimir Prom
Fin

5. Imprima el cubo de los elementos de un vector.

Inicio
Vo(10), Vc(10)
Hacer para I=1 hasta 10
Leer Vo(I)
Vo(I)=Vc(I)>3
Imprimir Vo(I)
Fin para I
Fin

6. Imprima los números impares.

Inicio
I=0
Hacer para I=1 hasta 50
I=I+2
Leer I
Imprimir IFin para I
Fin

7. Imprima los números positivos del 1 al 10.

Inicio
V(10)
Hacer para I=1 hasta 10
Leer V(I9
Si V(I)>0
Imprimir V(I)
Fin si
Fin para I
Fin

8. Imprima los primeros 15 números negativos.

Inicio
V(J)=15
Hacer para J=1 hasta 15
Leer (J)
Si V(J)mayor
Me=Me+1Sino
Ma=ma+1
Sino Ma=Me+1
Fin si
Fin para I
Imprimir “Son” Ma “Mayor”
Imprimir “Son” Me”Menor”
Fin para I
Fin

27. Se tiene un arreglo unidimensional B de N elementos. Encontrar el mayor elemento y su posición en el arreglo.

Inicio
N=0, Mayor=0, I=0, Pos=o
Leer N
B(N)
Hacer para I=1 hasta NLeer B(I)
Si I=1
Mayor=B(I)
Fin si
Hacer para I=2 hasta N
Leer B(I)
Si Mayor>B(I)
Mayor=BC(I)
Pos=I
Fin si
Fin para I
Imprimir “El elemento mayor “Mayor” en la posición “Pos”
Fin para I
Fin

28. Crear e imprimir un arreglo unidimensional de 20 elementos un valor igual al inverso de la posición queocupa.

Inicio
I=0, J[20]
Hacer para I=20 hasta 1
Leer J(I)
Imprimir J(I)
Fin para I
Fin

29. Se tiene un arreglo unidimensional X de N elementos. Lea dicho arreglo y además lea la variables clave y encuentre si el valor de la clave se encuentra uno dentro desarreglo X. En caso de encontrarse se debe indicar cuantas veces aparece dicho valor en elarreglo.

Inicio
I=0, N=0, Clave=0, C=0, J(20)
Leer N, Clave
Hacer para I=1 hasta N
Leer J(I)
Si J(I)=Clave
C=C+1
Sino
Fin si
Fin para I
Imprimir C
Fin

30. Un hombre planea invertir 500 dólares por año al 6% de interés cuanto requiere para acumular B/. 10,000? Se debe obtener el año en el cual su inversión...
tracking img