Resumen de listado

Solo disponible en BuenasTareas
  • Páginas : 6 (1267 palabras )
  • Descarga(s) : 4
  • Publicado : 20 de abril de 2010
Leer documento completo
Vista previa del texto
25/03/2010

JLD Excel en Castellano - Usar Microsof…

Go [ Location via proxy: http://jldexcelsp.blogspot.com/2009/10/extraer-elementos-unicos-y-repetidos.html UP ] No cookies No scripts No ads No referrer

JLD EXCEL
Inicio

EN

CASTELLANO - USAR MICROSOFT EXCEL
Ayuda Consultoría Apoyar JLD Excel

EFICIENTEMENTE

Sugerencias y ayuda para Excel en español. Ejemplos de funciones yfórmulas, gráficos y automatización de hojas de cálculo con Vba.

Acerca de JLD Excel

TRADUCIR EST A PÁGINA
Autofiltro Consolidar Datos Dashboards Excel 2007

Fechas y
BUSCAR EN EL BLOG
Buscar

hora Formato Condicional Funciones y Formulas Graficos Importar Datos Macros Tablas Dinamicas Validacion de Datos Varios

Extraer elementos únicos y repetidos con fórmulas.
JUEVES, OCTUBRE 22,2009

Búsqueda personalizada

Si tenemos una lista de valores ordenados en una única columna podemos obtener una lista de los valores repetidos o de los valores únicos usando fórmulas. Supongamos esta lista de nombres. Los nombres repetidos los hemos marcado con un fondo de color usando Formato condicional

Entre su e-mail para suscribirse:

Suscribirse
Delivered by FeedBurnerSuscribirse a un lector de feeds

PUBLICIDAD

EST ADÍSTICAS

ARCHIVO DEL BLOG
Si queremos crear una lista de valores únicos en el rango B2:B19, usamos esta fórmula matricial: =INDICE(Lista,K.ESIMO.MAYOR((CONTAR.SI(Lista,Lista)=1)*FILA()1,FILA(INDIRECTO("1:"&FILAS(Lista)))))

Archivo del blog

RECOMENDADOS
Economía Excel - en Castellano Contextures Chip Pearson Decision Modelspzeg.com/…/687474703a2f2f6a6c6465…

1/6

25/03/2010

JLD Excel en Castellano - Usar Microsof…
ENLAZAR

Enlaza mi Blog

Dos observaciones importantes en relación a esta fórmula: 1 – ésta es una fórmula matricial y debe ser introducida apretando simultáneamente Ctrl+Mayúsculas+Enter 2 – ésta es una fórmula matricial “multicelular”, es decir, la misma fórmula da un resultado distinto en cada celda. Poresto primero debemos seleccionar el rango que va a ocupar la fórmula y luego introducirla. Si queremos obtener una lista de los elementos repetidos, modificamos levemente la fórmula =INDICE(Lista,K.ESIMO.MAYOR((CONTAR.SI(Lista,Lista)1)*FILA()1,FILA(INDIRECTO("1:"&FILAS(Lista)))))

De la misma manera, si queremos extraer los elementos que se repiten 3 veces (no los hay en el ejemplo), usaríamos=INDICE(Lista,K.ESIMO.MAYOR((CONTAR.SI(Lista,Lista)=3)*FILA()1,FILA(INDIRECTO("1:"&FILAS(Lista))))) Es decir, si queremos extraer los elementos que se repitan n veces, usamos =INDICE(Lista,K.ESIMO.MAYOR((CONTAR.SI(Lista,Lista)=n)*FILA()1,FILA(INDIRECTO("1:"&FILAS(Lista))))) Si queremos que los resultados #¡VALOR! no aparezcan podemos usar Formato condicional

pzeg.com/…/687474703a2f2f6a6c6465…2/6

25/03/2010

JLD Excel en Castellano - Usar Microsof…

Una breve explicación de las fórmulas: La fórmula =(CONTAR.SI(Lista,Lista)=1) genera un vector de valores VERDADERO o FALSO que multiplicamos por el número de fila para generar una serie ordenada =(CONTAR.SI(Lista,Lista)=1)*FILA()-1

Restamos 1 para dado que la primer fila en el rango es 2. Los nombres repetidos dan como resultado-1; los valores únicos dan el número de fila menos 1. Ahora tenemos que ordenar este vector, para lo que usamos K.ESIMO.MAYOR =K.ESIMO.MAYOR((CONTAR.SI(Lista,Lista)=1)*FILA()-1,FILA(INDIRECTO("1:"&FILAS(Lista))))

pzeg.com/…/687474703a2f2f6a6c6465…

3/6

25/03/2010

JLD Excel en Castellano - Usar Microsof…

Este vector nos sirve de argumento en la función INDICE para encontrar elelemento indicado. ¿Cómo haríamos para obtener los mismos resultados si los nombres estuvieran divididos en dos listas?

Technorati Tags: MS Ex ce l

Posted by Jorge L. Dunkelman at 7:45 PM Labels: Formato Condicional, Funciones y Formulas

8 comments:
Anónimo, 23 octubre, 2009 11:57 Hola Jorge: Una pregunta. ¿Por qué no repites en el segundo argumento del K.ESIMO.MAYOR la expresión...
tracking img