Sumar si

Solo disponible en BuenasTareas
  • Páginas : 6 (1293 palabras )
  • Descarga(s) : 0
  • Publicado : 31 de enero de 2012
Leer documento completo
Vista previa del texto
Funciones SUMAR.SI y CONTAR.SI
PLANILLA ELECTRÓNICA Excel

Función SUMAR.SI • En muchas ocasiones necesitaremos sumar un conjunto de valores, que podrán representar conceptos muy diversos, como por ejemplo:
– Sueldos de los funcionarios de una empresa – Las ventas diarias de una fábrica realizadas por cada vendedor – Los depósitos realizados en una cuenta bancaria durante un períododeterminado

• Para los casos en que los valores a sumar son TODOS los del conjunto, Excel nos provee la función SUMA.

• Sin embargo, habrá muchos otros casos en que los valores a sumar serán aquellos que cumplan con una o más condiciones (o criterios), que dependerán de los valores o de otros datos relacionados con ellos.

Supongamos que llevamos un recuento de las ventas de una farmacia enun mes determinado, y queremos totalizarlas por cada categoría de medicamentos (comprimido, jarabe, inyectable, etc.).

Queremos calcular el total de ventas en el mes de los medicamentos de la categoría Inyectable”.

Sintaxis de la función SUMAR.SI
• = SUMAR.SI (rango; criterio; rango_suma) • Rango : es el conjunto de celdas de las cuales se evaluará si cumplen o no el criterio. • Criterio:es la condición que deben cumplir las celdas de dicho. • Rango_suma: es el rango donde están las celdas cuyos valores se sumarán.

Resolvamos el ejercicio que estamos analizando (no se escribieron las referencias absolutas para no entorpecer la visualización de la función)

Observaciones: • En el ejemplo, el criterio se escribe como E4, es decir la denominación de la celda contra cuyovalor se compara. Si se quisiera comparar las celdas del rango directamente contra el valor “Comprimido”, la sintaxis de la función correspondiente sería: =SUMAR.SI(B2:B8,"=Inyectable",C2:C8) Es decir, la condición o criterio se pondría entre comillas.

Observaciones: • Hay que tener en cuenta que los criterios pueden ser muy diversos, y en cada caso habrá que encontrar el que corresponde con elproblema a resolver.

Múltiples condiciones
¿Qué pasa si queremos aplicar condiciones más complejas?

• Supongamos que queremos totalizar las ventas de los medicamentos de tipo “Inyectable”, pero solamente las de aquellos que superaron los 3.000 pesos en el mes... ¿es posible resolverlo mediante la función SUMAR.SI y con los datos disponibles en la planilla del ejemplo?

¿?



Larespuesta es NO, a menos que se utilicen otras fórmulas o funciones:

1) =SI 2) SUMAR.SI.CONJUNTO válida desde Excel 2007 3) Fórmulas matriciales 1) Una solución para resolver este problema, es utilizar una función SI auxiliar en una celda intermedia. Los criterios (o condiciones) que se le permite especificar a la función SUMAR.SI son menos potentes que los que se le permiten a la función SI. Se necesita una función SI en una celda intermedia

Función SUMAR.SI resultante

2)Función SUMAR.SI.CONJUNTO

Si se cuenta con Excel 2007, cuando se necesita inclui varias condiciones se puede utilizar la siguiente función:

SUMAR.SI.CONJUNTO(rango_suma,rango1_criterio,criterio1,rango2_cr iterio,criterio2…) Rango_suma son las celdas que se van a sumar, incluyendo números, o nombres,matrices o referencias que contienen números. Los valores en blanco y los de texto no se tienen en cuenta. Rango_criterio1, rango_criterio2, … son de 1 a 127 rangos en los que se van a evaluar los criterios asociados. Criterio1, criterio2, … son los criterios (hasta un máximo de 127) en forma de número, expresión, referencia de celda o texto que determinan las celdas que se van a sumar.

3)Otra alternativa para utilizar múltiples condiciones es ingresar una fórmula matricial

=SUMA(SI(B2:B8=F2;SI(C2:C8>F3;C2:C8)))
1ra. Condición “Comprimido ” 2da. Condición “>3000”

La función matricial sumará los importes de los artículos que cumplan las dos condiciones : “Comprimido” y “>3000”. Las funciones matriciales se ingresan como habitualmente y al final en lugar de Enter se presiona...
tracking img