Tamare

Solo disponible en BuenasTareas
  • Páginas : 2 (275 palabras )
  • Descarga(s) : 0
  • Publicado : 8 de noviembre de 2011
Leer documento completo
Vista previa del texto
Ejercicios Nivel B

1. Suma de los n primeros numeros naturales multiplos de 5

Proceso Suma_N_Primeros_Numeros_Naturales_multiplos_de_5


Escribir 'Ingrese numero de términos: '
LeerN


Suma <- 5*N * (N + 1) / 2


Escribir 'Suma = ', Suma

FinProceso

2. Numero minimo de billetes y monedas de billetes de 20, 10 y
monedas de 5 y 1 nuevo sol.

ProcesoNumero_Minimo_Billetes_Y_Monedas

Escribir 'Ingrese Monto: '
Leer Monto

Billetes20 <- trunc(Monto / 20)
Resto <- Monto MOD 20
Billetes10 <- trunc(Monto / 10)
Resto <- MontoMOD 10
Monedas5 <- trunc(Resto / 5)
Resto <- Monto MOD 5
Monedas1 <- trunc(Resto / 1)
Resto <- Monto MOD 1

NroMinBillMon <- Billetes20 + Billetes10 + Monedas5 + Monedas1Escribir 'Billetes20= ', Billetes20
Escribir 'Billetes10= ', Billetes10
Escribir 'Monedas5= ', Monedas5
Escribir 'Monedas1= ', Monedas1
Escribir 'NroMinBillMon= ', NroMinBillMonFinProceso

3. Multiplicar dos números complejos

Proceso Multiplicar_Dos_Nros_Complejos


Escribir 'Ingrese 1er. número complejo'
Escribir 'Parte Real : '
Leer a
Escribir 'Parte Imaginaria: '
Leer b

Escribir 'Ingrese 2do. número complejo'
Escribir 'Parte Real : '
Leer c
Escribir 'Parte Imaginaria : '
Leer d


ParteReal <- (a*c - b*d)
ParteImaginaria <-(a*d + b*c)


Escribir 'Producto = ', ParteReal,' + ',ParteImaginaria,' i'

FinProceso

4. Invetir un número de tres digitos

Proceso Invertir_numero_tres_digitos


Escribir'Ingrese Numero: '
Leer N


NroInv <- 0

NroInv <- (NroInv * 10) + (N MOD 10)
N <- trunc(N/10)

NroInv <- (NroInv * 10) + (N MOD 10)
N <- trunc(N/10)

NroInv <-(NroInv * 10) + (N MOD 10)


Escribir 'NroInvertido= ', NroInv

FinProceso

5. Producto escalar de dos vectores en el espacio


Proceso Producto_Escalar_de_dos_Vectores_en_el_Espacio...
tracking img