7 Pasos Para Programar

Páginas: 3 (621 palabras) Publicado: 9 de febrero de 2016
Universidad Mariano Gálvez
Centro Regional Villa Nueva
Ingeniería En Sistemas “B”
Ing. Roxana Díaz
Algoritmos
Vasty Mazariegos
Carné: 509015584


1) Definición del Problema:
Escriba un programa quepermita elegir entre opciones 1) vector edad 2) cadena nombre y apellido 3) mostrar datos según casilla 4) 0 para salir
El tipo vector permitirá el ingreso de las edades para los alumnos con unmáximo de 15 datos.
El tipo cadena permitirá del ingreso del nombre de los alumnos y de los apellidos en arreglos independientes.
Se preguntara al usuario que numero de casilla desea ver y se mostrara elnombre y apellido correspondiente de manera concatenada y a la vez la edad corresponde al mismo número de casilla.
2) Análisis del Problema:
La información necesaria para poder ejecutar este programaes conocer las instrucciones correctas que permita el funcionamiento del programa requerido y su manera de empleo como también los datos ingresado por el usuario.
3) Diseño de algoritmo
Definir Cont,aux, digito,pot, i como Real
Escribir "Ingrese un numero entero positivo:"
Leer n

cont <- 0
aux <- n
Mientras aux>0 hacer
cont <- cont + 1
aux <-trunc(aux/10)
FinMientras
Escribir "El numero tiene ",cont," digitos"


aux<-n
Para i<-1 hasta cont Hacer
pot <- 10^(cont-i)
digito <- trunc (aux / pot)
aux <-aux - digito*pot
Escribir "El digito ",i," es ",digito
FinPara

FinProceso



4) Codificación:
Definir Cont, aux, digito,pot, i como Real
Escribir "Ingrese un numero enteropositivo:"
Leer n

cont <- 0
aux <- n
Mientras aux>0 hacer
cont <- cont + 1
aux <- trunc(aux/10)
FinMientras
Escribir "El numero tiene ",cont," digitos"aux<-n
Para i<-1 hasta cont Hacer
pot <- 10^(cont-i)
digito <- trunc (aux / pot)
aux <- aux - digito*pot
Escribir "El digito ",i," es ",digito...
Leer documento completo

Regístrate para leer el documento completo.

Estos documentos también te pueden resultar útiles

  • 7 pasos para perdonar
  • 7 pasos para la restauración
  • 7 pasos para la elaboracion de un programa
  • 7 pasos para estar en hollywood
  • 7 Pasos Para El Desarrollo De Un Programa
  • 7 Pasos para crear una empresa
  • 7 Pasos para conocer a dios
  • 7 Pasos Para Solucionar Los Problemas

Conviértase en miembro formal de Buenas Tareas

INSCRÍBETE - ES GRATIS