Algoritmos

Páginas: 6 (1286 palabras) Publicado: 10 de octubre de 2010
ALGORITMOS

PRESENTADO POR:

PRESENTADO A:

“TUTOR”

Realizar un algoritmo que permita leer 20 temperaturas diferentes durante un dia, se debe indicar cual fue la temperatura promedio de ese dia

INICIO
NUMERO: temp, prom, cont
temp=0
prom=0
cont=0
MIENTRAS cont < 20
LEER temp
prom=prom+temp
cont=cont+1
FIN MIENTRAS
prom=rom/cont
MOSTRAR: prom
FIN

Prueba de escritorio:INICIO

MIENTRAS cont < 20
/*lee las 20 temperaturas
LEER: 19 +16+ 32 +28 + 30 +31 +20 +25+24+29+27+32+35+30+35+35+31+20+19+30
/*sumatoria de las temperaturas
prom=548
/*cont llega a 20 y termina el ciclo
cont=20
FIN MIENTRAS
/*calculo el promedio
prom=548/20
MOSTRAR: 27,4
FIN

se desea desarrollar un algoritmo que permita, desarrollar la tabla de multiplicar de un determinadonumero

INICIO
NUMERO: cont = 0, valor = 0
LEER valor
cont=1
MIENTRAS cont =< 10
ESCRIBIR cont * valor
cont=cont + 1
FIN MIENTRAS
FIN

Prueba de escritorio:

INICIO
NUMERO: cont = 0, valor = 0
/* para el la prueba se mostrara la tabla del 3
LEER valor=3
cont=1
MIENTRAS cont =< 10
ESCRIBIR cont * valor
/*imprime todos los valores durante el ciclo
ESCRIBIR 3
ESCRIBIR 6ESCRIBIR 9
ESCRIBIR 12
ESCRIBIR 15
ESCRIBIR 18
ESCRIBIR 21
ESCRIBIR 24
ESCRIBIR 27
ESCRIBIR 30
/*finaliza el ciclo llegando a 10
cont=10
FIN MIENTRAS
FIN
desarrollar un algoritmo que permita mostrar las tablas del 1 al 9.

INICIO
NUMERO: cont, num
num=1
MIENTRAS num =1)
/se inicia el ciclo con valor=3 no termina mientras sea mayor a 1
facto=3*2*1
/*el ciclo termina cuando valor esigual a cero
valor=0
Fin Mientras
Mostrar: 6
FIN

una empresa con 20 empleados desea saber cuantos ganan entre uno y dos salarios minimos, cuantos ganan entre 2 y 5 salarios minimos, y cuantos ganan mas de 5 salarios minimos, ademas cual es el valor actual de la nomina de la empresa, cuanto aumentara la nomina mensual si se hace incrementos asi; 8% a los que ganan entre 1 y 2 salariosminimos y 5% a los que gana entre 2 y 5salarios minimos, y 3 % a aquellos que ganan mas de 5 salarios minimos. Se debe realizar los calculos teniendo en cuenta el valor del salario minimo vigente (461.500)

INICIO
NUMERO i, salario, unoydos, dosycinco, mascinco, nominaActual, nominaAumento
TEXTO: nombre

DESDE i=1 HASTA 20
LEER: salario
SELECCIONAR salario
CASO >461500 Y 923000 Y2307500
mascinco = mascinco + 1
nominaAumento = nominaAumento + (salario * 1,03)
FINCASO
nominaActual = nominaActual + salario
FIN_DESDE
MOSTRAR: “personas que ganan entre uno y dos salarios minimos” . unoydos
MOSTRAR: “personas que ganan entre dos y cinco salarios minimos” . dosycinco
MOSTRAR: “personas que ganan mas de 5 salarios minimos” . mascinco
MOSTRAR: “Nomina Actual :” .nominaActual
MOSTRAR: “Nomina con Incremento :” . nominaAumento

FIN

Prueba de escritorio:

INICIO
NUMERO i, salario, unoydos, dosycinco, mascinco, nominaActual, nominaAumento

DESDE i=1 HASTA 20
/*lee el salario
LEER: 1,005,000
/* se selecciona la variable caso y se compara con las 3 opciones posibles
SELECCIONAR salario
CASO >461500 Y 923000 Y 2307500
mascinco = mascinco + 1nominaAumento = nominaAumento + (salario * 1,03)
FINCASO
/en esta variable se guardara la sumatoria de la nomina(nominaActual), en este caso sumara 1,005,000 que es el salario del trabajador que se esta registrando
nominaActual = nominaActual + 1,005,000
FIN_DESDE
MOSTRAR: “personas que ganan entre uno y dos salarios minimos” . unoydos
MOSTRAR: personas que ganan entre dos y cinco salariosminimos 8
MOSTRAR: “personas que ganan mas de 5 salarios minimos” . Mascinco
/* se muestran los valores de la nomina actual haciendo una estimacion y tambien para el aumento
MOSTRAR: “Nomina Actual :” . 56,200,000
MOSTRAR: “Nomina con Incremento :” . 64,000,000

FIN
Se desea desarrollar un algoritmo que permita determinar el promedio de las edades de los alumnos del curso, ademas se debe...
Leer documento completo

Regístrate para leer el documento completo.

Estos documentos también te pueden resultar útiles

  • Algoritmos
  • Algoritmos
  • Algoritmos
  • Algoritmos
  • Algoritmos
  • Algoritmo
  • algoritmo
  • Algoritmos

Conviértase en miembro formal de Buenas Tareas

INSCRÍBETE - ES GRATIS