Ejemplos de programas pseint

Solo disponible en BuenasTareas
  • Páginas : 2 (338 palabras )
  • Descarga(s) : 0
  • Publicado : 12 de mayo de 2011
Leer documento completo
Vista previa del texto
Problema
1.- calcula el valor a pagar de un producto y el impuesto IVA
2.-
Datos de entrada | Datos de salida |
* Cantidad * El IVA se incluye en el precio | * Valor del IVA |Proceso
El usuario desea saber la cantidad del impuesto que se paga por un producto.
Formulas
IVA= (X*iva)/2
Código
Proceso impuesto_de_un_producto
Repetir


Escribir "impuesto de unproducto";
Escribir "introduce el precio del producto"
Leer precio;
si precio >0 Entonces
iva <-precio*.16
Escribir "el impuesto de tu producto es",iva:

FinSi
Escribir"deseas introducir otro numero (1=si,2=no)";
Leer respuesta;
Hasta Que respuesta =2

FinProceso
Diagramación

Pruebas de escritorio
precio | (x)(iva) |
5 | 5.8 |
10 | 11.6 |
15 | 17.4 |20 | 23.2 |

Problema
Calcular el porciento de un producto
Datos de entrada | Datos de salida |
* Cantidad * El IVA | * Valor del porciento * según la cantidad dada |
Código
//calcular el tanto porciento de un prducto
Proceso sin_titulo
Repetir
Repetir
Escribir "introduce elvalor del producto"
Leer presio
Hasta Que presio >0 Repetir
Escribir "introduce el IVAdel producto"
Leer iva
Hasta Que iva<1
porcentaje<-presio*iva
Escribir "el porcentaje de tu producto es:",porcentaje;
Escribir "decea realizar otro calculo (1=si,2=no)"
Leer respuestaHasta Que respuesta =2

FinProceso

pruebas de escritorio
Producto | %(X) |
1000 | 100 |
2000 | 200 |
50000 | 5000 |

Problema
Calcular el impuesto de 3 productos
Datos de entrada |Datos de salida |
* Precio1 * Precio2 * Precio 3 | * El impuesto de los tres productos |

// calcular el impuesto de tres productos
Proceso impuesto_3_productos
Repetir
RepetirEscribir "introdice el precio1"

Leer a
Hasta Que a >0
Repetir
Escribir "introdice el precio2"
Leer b
Hasta Que b >0
Repetir
Escribir "introdice el precio3"...
tracking img