Ingenieria en sistemas

Solo disponible en BuenasTareas
  • Páginas : 2 (314 palabras )
  • Descarga(s) : 7
  • Publicado : 24 de junio de 2010
Leer documento completo
Vista previa del texto
1°. Imprimir el valor absoluto de un número.

Inicio
Leer = NRO
VAB= (NRO=NRO)
Imprimir VAB
Fin

2°. El dueño de una tienda compra un articulo a un precio determinado,obtener el precio en que lo debe vender para obtener una ganancia del 30%.

Inicio
Leer COMP
GAN= PCOMP*0.30
PVEN= PCOMP+GAN
Imprimir PVEN
Fin3°. Tres personas deciden invertir su dinero para fundar una empresa cada una de ellas invierte una cantidad distinta.
Obtener el % que cada quien invierte con respecto a la cantidadtotal invertida.
Inicio
Leer INV1, INV2, INV3
INVT= (INV1+INV2+INV3)
PINV1= (INV1/100)
PINV2= (INV2/100)
PINV3= (INV3/100)
Imprimir INVT, PINT1, PINV2, PINV3
Fin4°. Imprimir el equivalente en monedas y billetes de una cantidad X de lempiras.
Inicio
Leer: CANT
MOD=CANT/0.10
MOV=CANT/0.20
MOC=CANT/0.50
B U=CANT/1
BD=CANT/2
B C=CANT/5
B D=CANT/10
B V=CANT/20
B C=CANT/50
B C=CANT/100
B Q=CANT/500
Imprimir MOD, MOV, MOC, B U, B D, B C, B D, B V, B C, B C, B Q
Fin5°. Calcular el total a pagar por la compra de camisas si se compran 3 camisas o mas que aplique un descuento del 20%, si son menos de 3 el descuento será de 7%.Inicio
Leer= CC
TC=CC*P
IF CC>=3 THEN
DES=TC*0.20
TPG=TC-DES
ELSE
DES=TC*0.07
TPG=TC-DES
FINSI
Imprimir TPG, DES














6°.Leer 2 números si son iguales que los multiplique, si el primero es mayor que el Segundo lo reste y si no que lo sume.
Inicio
Leer: N1, N2
IF N1=N2 THEN
RES= (N1*N2)
ELSEIF N1>N2 THEN
RES=N1-N2
ELSE
RES= N1+N2
FINSI
FINSI
Imprimir RES
Fin
tracking img