Algoritmo

Solo disponible en BuenasTareas
  • Páginas : 2 (351 palabras )
  • Descarga(s) : 0
  • Publicado : 9 de marzo de 2011
Leer documento completo
Vista previa del texto
Lenguaje Pseudoformal Declaración de variables: i, n, Pu, Pd, Am, Ap, Ag, Tu, Td: Entero; Pg, Pp, Peso, Est: Real Nomb: Carácter; Inicio Ap=0; Ag=0; Imprimir"Cuantos animales hay en la plantaalta"; Leer(Pu); Imprimir"Cuantos animales hay en la planta baja"; Leer(Pd); Si n21)hacer Imprimir"De cuantos animales consta la nueva colección"; Leer(n); Fin Si; Para(i=1 hasta =n)hacerImprimir"Ingrese nombre del animal"; Leer(Nomb); Imprimir"Ingrese estatura del animal"; Leer(Est); Imprimir"Ingrese el peso del animal"; Leer(Peso); Si(Est>Peso)entonces Ap=Ap+1; Sino Ag=Ag+1; Fin Si Fin ParaTu=Pu+Ap; Td=Pd+Ag; Pp=(Ap*100)/n; Pg=(Ag*100)/n; Si(Tu>Td)entonces Am=(Tu-Td)/2; Sino Am=(Td-Tu)/2; Fin Si Imprimir"El porcentaje de animales pequeños es: ",Pp; Imprimir"El porcentaje de animalesgrandes es: ",Pg; Imprimir"Animales en la planta alta: ",Tu; Imprimir"Animales en la planta baja: ",Td; Imprimir"Animales a mover: "Am; Fin

Lenguaje C #include int main() { int i, n, Pu, Pd, Am, Tu,Td, Pp, Pg; float Peso, Est; char Nomb; int contadorAp= 0; int contadorAg= 0; printf("Cuantos animales hay en la planta alta\n"); scanf("%d",&Pu); printf("Cuantos animales hay en la plantabaja\n"); scanf("%d",&Pd); printf("De cuantos animales consta la nueva coleccion (Solo hasta 20 Ejemplares)\n"); scanf("%d",&n); { if((n>0) && (nTd) Am=(Tu-Td)/2; else Am=(Td-Tu)/2;

printf("Elporcentaje de animales pequenos es: %d %\n",Pp); printf("El porcentaje de animales grandes es: %d %\n",Pg); printf("Animales en la planta alta: %d\n",Tu); printf("Animales en la planta baja: %d\n",Td);printf("Animales a mover: %d\n",Am); return 0; }

Identificación de Variables. Pu: Planta alta. Pd: Planta Baja. Am: Animales Grandes. Tu: Total de animales en la Planta Alta. Td: total de animales enla Planta Baja. Pp: Porcentaje de Animales Pequeños. Pg: Porcentaje de Animales Grandes. Am: Animales a Mover. Peso: Peso del animal. Est: estatura del animal. Nomb: Nombre del Animal.

tracking img