Codigo c y pseudocodigo

Páginas: 3 (577 palabras) Publicado: 21 de agosto de 2012
Trabajo Práctico 1
Materia: Informática Carrera: Ing. Electrónica Profesora : Mónica Denham Integrantes: Alexis Sandoval, Luciano Santibañez Fecha de entrega: 4/05/12 Nota Final:

TrabajoPráctico 1-Informática

Introducción
En este trabajo práctico se desarrollarán las soluciones de los ejercicios 21,79 (implementando el ejercicio 77,78,79) y el ejercicio 107, de la ejercitación número 2(ejercicios de programación en lenguaje C). Estas soluciones estarán dadas tanto en pseudocódigo como en código C. También se detallarán los problemas hallados durante la resoluciones y también lassoluciones encontradas a dichos problemas.

1 de 11

Trabajo Práctico 1-Informática

Ejercicio 21.
Hacer un programa que, dada una operación (+, -, *, /) y dos números decimales realice laoperación indicada con ellos y muestre su resultado.

Solución en pseudocódigo
Inicio Leer(operador) Leer(numero1) Leer(numero2) Si(operador== '+' ) resultado=(numero1+numero2) printf("El resultadoes",resultado) FinSi Si(operador== '-' ) resultado=(numero1-numero2) Imprimir("El resultado es",resultado) FinSi Si(operador== '*' ) resultado=(numero1*numero2) Imprimir("El resultado es”,resultado) FinSiSi(operador== '/' ) Si(numero2==0) Imprimir("error división por 0”) Imprimir(“el resultado es:9999999") FinSi
2 de 11

Trabajo Práctico 1-Informática

SiNo resultado=(numero1/numero2)Imprimir("El resultado es",resultado) FinSino FinSi Fin

Solución en código C
#include void main() { float numero1; float numero2; float resultado; char operador; printf("Ingrese caracter: ");scanf("%c",&operador); printf("Ingrese numero 1: "); scanf("%f",&numero1); printf("Ingrese numero 2: "); scanf("%f",&numero2); if (operador=='+') { resultado=(numero1+numero2); printf("El resultado es%.3f\n",resultado); } if(operador=='-') { resultado=(numero1-numero2); printf("El resultado es %.3f\n",resultado); } if(operador=='*') { resultado=(numero1*numero2); printf("El resultado es %.3f\n",resultado);...
Leer documento completo

Regístrate para leer el documento completo.

Estos documentos también te pueden resultar útiles

  • codigo c
  • codigos c++
  • Codigos en c++
  • Codigo C++
  • Tipos de datos en Pseudocódigo y en Lenguaje C
  • Codigo c++ biulder
  • Codigo Detest Visual C#
  • Código En C De La Curp y Rfc

Conviértase en miembro formal de Buenas Tareas

INSCRÍBETE - ES GRATIS