Algoritmos

Solo disponible en BuenasTareas
  • Páginas : 6 (1430 palabras )
  • Descarga(s) : 0
  • Publicado : 8 de junio de 2011
Leer documento completo
Vista previa del texto
Presentación
COBAEV 28
Asignatura: Informática II
Profesor: Gabriel Aguilar Huerta
Alumno:
Justino Hernández Cortés
Trabajo: “Algoritmos”
Grupo: 206
Lugar: Tlapacoyan, Ver.
Fecha: 09 de marzo del 2011

Reporte 1 “El mundo de Karel”
Karel el robot es un pequeño programa que nos introduce al mundo de la programación de software solo que con un lenguaje bastante sencillo y con una seriede algoritmos que hay que introducirle al “robot”.
Su entorno grafico es simple en una flechita () de color azul su mundo es un tipo de laberinto en el que se ira moviendo dependiendo lo que le ordenes.
Entre sus ordenes se encuentra “avanza” que es para que avance una cuadra, si deseas que avance mas cuadras tienes que repetir “avanza” el numero de veces que deseas que avance, si quieres quegire tendrás que poner “gira-izquierda” ya que solo gira hacia la izquierda, y si quieres que gire a la derecha tendrás que repetir “gira-izquierda” tres veces, también dentro de sus ordenes se encuentra “coge-zumbador” para atrapar un zumbador en su “mochila” y para atrapar vario se hace lo mismo que con “avanza” y “coge-zumbador”.
Una vez que lo hayas programado y este completo el algoritmodebes dar click en copilar y si esta correcto te pondrá un mensaje de “programa copilado” y en caso de que no te dirá un error, si esta correcto “ejecutar” e iniciar tu algoritmo.

Reporte 2 “El mundo de Karel”
Esta vez nos tocaba practicar con el programa por primera vez, primero buscamos el programa, abrimos inicio, después fuimos a Mi PC y abrimos la unidad de disco duro (C:) y allí seencontraba la carpeta Karel, una vez abierta la carpeta le di abrir a la aplicación, ya abierta fui a la pestaña programa y di click en nuevo para proceder a escribir las instrucciones que el profesor había escrito en el pizarrón.
Estas son las instrucciones que el profesor nos dio:
↑ 7 cuadras → 6 cuadras ↑ 2 cuadras← 3 cuadras↓ 2 cuadras |

Una vez escrito todo rectifique que estuviera todobien escrito y como no encontré ningún error procedí a copilar el programa y pasar a la pestaña “ejecutar” para correr el programa y cambiar el retardo de ejecución de 500 ms a 100 ms para que fuera mas rápido y terminar pronto.

Algoritmo:

iniciar-programa
inicia-ejecucion
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
gira-izquierda;gira-izquierda;
gira-izquierda;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
gira-izquierda;
avanza;
avanza;
gira-izquierda;
avanza;
avanza;
avanza;
gira-izquierda;
avanza;
avanza;
apagate;
termina-ejecucion
finalizar-programa

Reporte 3 “El mundo de Karel”
Pues esta ocasión nos tocaba usaruna nueva instrucción que era “coge-zumbador” y cumplir con las coordenadas:
(7, 5) X, Y(15, 3) X, Y |

Primero procedí a girar tres veces hacia la izquierda para ir hacia la derecha y avanzar las primeras seis cuadras, luego a girar y avanzar cuatro cuadras mas y coger el zumbador que se encontraba en esa posición, luego gire a la izquierda tres veces mas y avance ocho veces luego gire 3veces y procedí a avanzar 2 mas para coger el zumbador que faltaba y como ya habíamos terminado procedimos a copiar el algoritmo.

Algoritmo:

iniciar-programa
inicia-ejecucion
gira-izquierda;
gira-izquierda;
gira-izquierda;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
gira-izquierda;
avanza;
avanza;
avanza;
avanza;coge-zumbador;
gira-izquierda;
gira-izquierda;
gira-izquierda;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
avanza;
gira-izquierda;
gira-izquierda;
gira-izquierda;
avanza;
avanza;
coge-zumbador;
apagate;
termina-ejecucion
finalizar-programa

Reporte 4 “El mundo de Karel”
Esta...
tracking img