Algoritmos

Solo disponible en BuenasTareas
  • Páginas : 2 (329 palabras )
  • Descarga(s) : 0
  • Publicado : 7 de noviembre de 2011
Leer documento completo
Vista previa del texto
1) Se leen tres datos que representan el nombre, sueldo básico y antigüedad
de un empleado y se debe escribir el nombre y el sueldo a cobrar. El sueldo se
calcula, adicionando al básico el 15 %del mismo, si la antigüedad supera los 3
años; 30 % del mismo, si la antigüedad supera los 6 años y 50 % del mismo, si la
antigüedad supera los 10 años.

AMBIENTE

NOMBRE VARIABLE TIPOCARÁCTER, CONTIENE EL NOMBRE DEL EMPLEADO

SUELDOBASICO VARIABLE TIPO NUMERICO REAL, CONTIENE EL SUELDO BASICO DEL EMPLEADO

ANTIGüEDAD VARIABLE TIPO NUMERICO, CONTIENE LA ANTIGüEDAD DEL EMPLEADO EN AÑOSSUELDO VARIABLE TIPO NUMERICO REAL, CONTIENE EL SUELDO LIQUIDADO DEL EMPLEADO

1 INGRESO DE DATOS
2 CALCULO DE SUELDO
3 INFORMAR EL SUELDO

1.1 LEER NOMBRE
1.2 LEER SUELDOBASICO
1.3 LEERANTIGüEDAD
2.1 SI ANTIGüEDAD = 3
ENTONCES
SUELDO ← SUELDO * 1.15
SINO
SI ANTIGüEDAD = 6
ENTONCES
SUELDO ← SUELDO * 1.30
SINO
SI ANTIGüEDAD = 10
SUELDO ← SUELDO * 1,50
FINSI
FINSIFINSI
3.1 ESCRIBIR “EL EMPLEADO” EMPLEADO
3.2 ESCRIBIR “COBRARA DE SUELDO” SUELDO

2) Escribir un algoritmo que determine en la variable MINIMO el menor de
los valores de cuatro variablesnuméricas.

AMBIENTE

CONTADOR VARIABLE TIPO NUMERICO, CONTADOR PARA EL CICLO REPETITIVO

MIN VARIABLE TIPO NUMERICO, VARIABLE DONDE ALMACENO EL NUMERO MENOR

CONTADOR = 1

LEER MIN
MIENTRAS CBENTONCES
MIN ← B
FINSI
C = C+1
FINMIENTRAS
ESCRIBIR MIN

3) Se leen tres valores que corresponden al día, mes y año. Verificar si los
datos constituyen una fecha posible o no.

DIAVARIABLE TIPO NUMERICO, VARIABLE DONDE ALMACENO EL NUMERO DE DIA

MES VARIABLE TIPO NUMERICO, VARIABLE DONDE ALMACENO EL NUMERO DE MES

AÑO VARIABLE TIPO NUMERICO, VARIABLE DONDE ALMACENO EL NUMERO DEAÑO

FECHA VARIABLE TIPO CARACTER, VARIABLE DONDE INDICO SI ES VALIDA LA FECHA O NO

1 LEEMOS LOS DATOS
2 ANALISAMOS Y COMPARAMOS LOS DATOS
3 MOSTRAMOS RESULTADO

1.1 LEER DIA
1.2 LEER...
tracking img