Hack

Solo disponible en BuenasTareas
  • Páginas : 8 (1829 palabras )
  • Descarga(s) : 0
  • Publicado : 28 de febrero de 2012
Leer documento completo
Vista previa del texto
Tutorial de Karel el robot
Les advierto, en este pequeño taller no van a aprender a programar en ningun lenguaje que les servira en el futuro.

Aprenderan la sintaxis de Java y/o de Pascal pero NO aprenderan las instrucciones nativas de ninguno de estos.

En este taller aprenderan a programar a un robot virtual llamado Karel.

Antes que nada yo no hize Karel, ni ayude a su desarrollo, sololo encontre, lo use y me gusto para hacer este taller.

Karel es un robot, con forma de flecha azul xD
es tonto.
no sabe nada mas que:
 avanza;
 gira-izquierda;

ah y:
 coge-zumbador;
 deja-zumbador;

Bueno, pero tiene buena memoria, y es muy obediente.

Este programa se usa en la OMI y desconozco si se use en la IOI tambien.

En fin, "Karel el robot" (de ahora en adelante Karel)puede recibir las instrucciones antes mencionadas.. y vive en un mundo de cuadritos grises, de 100x100.

Este es un ejemplo de Karel en acción:

[pic]

Lo pueden descargar aqui:

http://www.olimpiadadeinformatica.org.mx/Karel.htm

Hay otras versiones (las originales) pero en ingles y para java aqui:

http://csis.pace.edu/~bergin/KarelJava2ed/KJRDistribution060110.ziphttp://csis.pace.edu/~bergin/KarelJava2ed/kareluniverse/kareluniversedist060309.zip
http://www.wiley.com/college/pattis/0471597252/instructor/karel.exe
http://sourceforge.net/project/showfiles.php?group_id=8696
etc..

En fin, abrimos el programa, nos vamos a la pestaña de Mundo.

En la esquina inferior izquierda, y viendo hacia arriba, se encuentra Karel.

si dan click derecho en una zona blanca, podranver un menu contextual, donde les preguntan si quieren colocar a Karel en ese lugar, y si quieres poner algun zumbador en ese lugar. si dan click al lado de un cuadro gris, se pondra una pared [pic].

en fin.. hagamos un "Hola Mundo" (o su equivalente) en Karel.

ponemos a karel (orientado al norte) en las coordenadas: 2,2 es decir aqui:
[pic]

Nos vamos a la pestaña de Programa.
damosclick en Nuevo.

vamos a ver esto:
Código:

iniciar-programa

    inicia-ejecucion

        apagate;

    termina-ejecucion

finalizar-programa


esto hace:

Código:

inicia el programa

    inicia lo que va a ejecutar

        apaga a karel

    termina lo que va a ejecutar

finaliza el programa


[pic] facil, no?

Todo lo que queramos que haga karel, lo debemos ponerdespues de:
inicia-ejecucion
y antes de:
termina-ejecucion

ojo!! NUNCA pero NUNCA pongan acentos.

ahora, si queremos que Karel haga algo, pues empezamos a ordenarle:

Código:

iniciar-programa

    inicia-ejecucion

        avanza;

        apagate;

    termina-ejecucion

finalizar-programa

le agregué una linea al programa.. esta:
Citar

iniciar-programa
   inicia-ejecucion
        avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Damos click en el botón COMPILAR.
es muy importante sino no funciona.. acostumbrence a oprimir ese botón, en la gran mayoria de los lenguajes sino es que todos se necesita hacer algo similar antes de ver que hace tu programa.

Una vez que dimos click en COMPILAR. nos vamos a la pestaña de Ejecutar.

Yahi, al botón Ejecutar.

Genial, Karel avanza un espacio, y se apaga.

Damos Aceptar, y regresamos a la pestaña de Programa.
despues del avanza le agregamos un gira-izquierda;

OJO!! es MUY importante que al finalizar cada instrucción agreguen un "punto y coma" = ";"

El código queda asi:
Citar

iniciar-programa
    inicia-ejecucion
        avanza;
        gira-izquierda;
       apagate;
    termina-ejecucion
finalizar-programa

Damos click a COMPILAR!!
Vamos a la pestaña de Ejecución.
Damos Correr.

y listo, Karel:
  avanza y despues gira a la izquierda

regresamos a Programa.

despues del gira-izquierda agregamos 2 avanza;

queda asi:
Citar

iniciar-programa
    inicia-ejecucion
        avanza;
        gira-izquierda;
        avanza;
        avanza;...
tracking img