Pseint ejercicios básicos

Solo disponible en BuenasTareas
  • Páginas : 5 (1239 palabras )
  • Descarga(s) : 0
  • Publicado : 13 de marzo de 2012
Leer documento completo
Vista previa del texto
//Con este programa podrás saber si el número en el que pensás está en el rango establecido o no.
//Rango: 35 a 50 ó 65 a 90.
//Variable
//a
Proceso Ejercicio1
Escribir "decime el numero pensado."
Leer a
si a>=35 y a<=50 o a>=65 y a<=90 Entonces
Escribir "El numero esta dentro del rango establecido."
Sino
Escribir "El numero no esta dentro del rango establecido."FinSi
FinProceso
//Con este programa sabrás fácilmente si el número en el que pensás es par o impar.
//Variable
//a
//Pequeño margen de error, al ingresar números grandes.
Proceso Ejercicio2
Escribir "Escribi el numero en el que estas pensando."
leer a
si a mod 2=0 Entonces
Escribir "El numero es par."
sino Escribir "El numero es impar."
FinSi
FinProceso

//Con ayuda de esteprograma te diré cuál es tu nombre completo.
//Variables
//a, b, e, f
Proceso Ejercicio3
Escribir "Cual es tu primer nombre?"
Leer a
Escribir "Cual es tu segundo nombre?"
Leer b
Escribir "Cual es tu primer apellido?"
Leer e
Escribir "Cual es tu segundo apellido?"
Leer f
Escribir "Tu nombre completo es:", a, b, e, f

FinProceso

//Con este programa sabrás si la letra queescribes es consonante o vocal.
//Variable
//a
Proceso Ejercicio4
Escribir "Dime la letra."
Leer a
Si a="a" o a="e" o a="i" o a="o" o a="u" Entonces
Escribir "La letra es vocal."
Sino Escribir "La letra es consonante."
FinSi
FinProceso

//Este programa es totalmente copiado de un ejemplo que PSeInt proporciona, ya que yo no pude realizar el algoritmo.
//calcula las raices de unaecuacion de segundo grado

Proceso Ejercicio5

// cargar datos
Escribir "Ingrese el coeficiente A:";
Leer a;
Escribir "Ingrese el coeficiente B:";
Leer b;
Escribir "Ingrese el coeficiente C:";
Leer c;

// determinar si son reales o imaginarias
disc <- b^2-4*a*c;
Si disc<0 Entonces
// si son imaginarias
preal<- (-b)/(2*a);
pimag<- rc(-disc)/(2*a);Escribir "Raiz 1: ",preal,"+",pimag,"i";
Escribir "Raiz 2: ",preal,"-",pimag,"i";
Sino
Si disc=0 Entonces // ver si son iguales o distintas
r <- (-b)/(2*a);
Escribir "Raiz 1 = Raiz 2: ",r;
Sino
r1 <- ((-b)+rc(disc))/(2*a);
r2 <- ((-b)-rc(disc))/(2*a);
Escribir "Raiz 1: ",r1;
Escribir "Raiz 2: ",r2;
FinSi
FinSi

FinProceso

//Con esta aplicaciónsabrá de cuánto son los precios de una tienda, tomando en cuenta descuentos.
//Variables
//a, b
Proceso Ejercicio6
Escribir "De cuanto fue su gasto?"
leer a
si a<=300 Entonces
Escribir "Usted no tiene descuentos. Su compra equivale a:", a
FinSi
si a>300 y a<=500 Entonces
b<-a*5/100
Escribir "su descuento sera del 5%, equivalente a:", b;
Escribir "Y su total apagar de:", a-b;
FinSi
si a>500 y a<=800 Entonces
b<-a*10/100
Escribir "su descuento sera del 10%, equivalente a:", b;
Escribir "Y su total a pagar de:", a-b;
FinSi
si a>800 Entonces
b<-a*12/100
Escribir "su descuento sera del 12%, equivalente a:", b;
Escribir "Y su total a pagar de:", a-b;
FinSi
FinProceso

//Averiguar qué número es mayor, cuál menor ycuál es el del medio.
//Variables
//a, b, c
Proceso CondicionalSi (mayor, mediano o igual)
Escribir "Con ayuda de este programa podras ordenar los numeros de varias formas."
Escribir "Dime el primer numero"
Leer a
Escribir "Dime el segundo numero"
leer b
Escribir "Dime el tercer numero"
leer c
Si a<b & b<c Entonces
Escribir "El menor es", a, "El mediano es", b, "yel mayor es", c
FinSi
Si a<b & b>c & a<c Entonces
Escribir "El menor es", a, "El mediano es", c, "y el mayor es", b
FinSi
Si a<b & b>c & a>c Entonces
Escribir "El menor es", c, "El mediano es", a, "y el mayor es", b
FinSi
Si a>b & b>c Entonces
Escribir "El menor es", c, "El mediano es", b, "y el mayor es", a
FinSi
Si a>b...
tracking img