Algoritmia

Solo disponible en BuenasTareas
  • Páginas : 10 (2334 palabras )
  • Descarga(s) : 0
  • Publicado : 17 de marzo de 2012
Leer documento completo
Vista previa del texto
|ALUMNO: KENNY BAPTISTA |
|C.I: 15.173.261 |

4.- Noción de Vector

Nueva estructura de objeto, frecuentemente utilizada en informática y a la que seaplican numerosos tratamientos iterativos. Por ejemplo, supongamos una empresa con 40 sucursales y que deseamos calcular el total de rentas.

El procedimiento a seguir sería ir sumando cada elemento del vector.

a) Total ( Venta(1) + Venta(2) + Venta(3) + ... + Venta(40)

De esta forma se define el vector en algorítmica a través de un nº índice que va a indicar elelemento del vector con el cual estamos haciendo operaciones.

b) VENTA (I) ( I [1..40]

TOTAL ( 0 Variable donde vamos a almacenar la sumatoria.
Para I de 1 hasta 40 hacer
TOTAL ( TOTAL + VENTA(I)
Fin para

Definición de Vector:

Conjunto ordenado que contiene un nº fijo de elementos (su dimensión) decualquier tipo válido definido con la condición de que todos deben ser del mismo tipo.

Forma de declarar un vector:

|Vector tipo nombre [índice mínimo .. índice máximo] |

Ejemplo: Para el ejemplo anterior la declaración del vector quedaría de esta forma:

vector entero venta [1..40]
















4.1.- Operaciones convectores

Asignación

En general, los lenguajes de programación incluyen como mucho instrucciones de lectura/escritura de vectores completos, siendo muy pocos la que tienen definidas otras operaciones primitivas con el vector tomado como dato único.

La estructura de control asociada de manera natural con los vectores es la estructura de tipo "PARA"

Ejemplo:

AlgoritmoInicializar_Vector

Vector de reales V [1 .. 100]
Para i de 1 hasta 100 hacer
V(i) ( 0.0
Fin para

Final

En algunos lenguajes se permite la asignación directa entre vectores de igual dimensión y tipo.

La condición principal para poder realizar este tipo de asignaciones es que debe cumplirse que los dos vectores sean delmismo tipo y de la misma longitud.

u ( v el vector 'u' pasa a contener los datos de 'v'

Otra forma de hacer esta asignación es a través de la asignación de elemento en elemento. Este tipo de asignación es la que se realiza de forma común en programación, y la que utilizaremos en nuestros algoritmos.

Para i de 1 hasta n hacer
u(i) ( v(j)
Fin paraDe este modo veamos un ejemplo: Tenemos dos vectores con las mismas características (tipo y longitud). Se pretende intercambiar los datos entre dos vectores a ( b. Para ello utilizaremos un elemento de apoyo c.

Algoritmo Intercambio de vectores
Variables enteras i, n, c
Vectores de enteros a [1..100], b[1..100]
Escribir “Introduzcael número de elementos de los vectores”
Leer n
- Para i de 1 a n
Escribir “Introduzca el elemento a[“,i,”]”
Leer a[i]
Escribir “Introduzca el elemento b[“,i,”]”
Leer b[i]
- Fin_Para
- Para i de 1 a n
c ( a[i] Obsérvese como se realiza el proceso de
a [i] ( b[i]intercambio. Necesitamos la variable de
b [i] ( c apoyo para no perder por sobrescritura los datos de un vector.
- Fin_Para
- Para i de 1 a n
Escribir “a[“,i,”]=”,a[i]
Escribir “b[“,i,”]=”,b[i]
- Fin_Para


Final

4.1.1.- NECESIDAD DEL PREDIMENSIONAMIENTO POR EXCESO

Es muy importante entender que la zona de...
tracking img