Desarollo al juego mental de las ranas

Solo disponible en BuenasTareas
  • Páginas : 6 (1328 palabras )
  • Descarga(s) : 0
  • Publicado : 7 de noviembre de 2011
Leer documento completo
Vista previa del texto
INTRODUCCIÓN

El motivo de este trabajo tiene la finalidad de mostrar el desarrollo de un juego para ejercitar la mente, denominado “LAS RANAS” en el cual se hay tres ranas verdes perfiladas hacia la derecha y por ende su movilidad es hacia la derecha; de la misma forma se encuentran otras tres ranas color marrón perfiladas hacia el lado derecho, siendo este también su sentido de movilidad,estas ranas están situadas en unas piedras, siendo en total 7 piedras por donde podrán desplazarse las ranas. Inicialmente las ranas están situadas en las piedras 1, 2, 3 respectivamente y las ranas marrón se encuentran en las piedras 5,6 y 7; considerando que la numeración de las piedras se toma de izquierda a derecha.
La finalidad de este juego es intercambiar de posición a las 6 ranas, esdecir, que las ranas verdes queden en la posición inicial de las ranas marrón y viceversa en el caso de las ranas marrón. Desplazándose de cada una de estas ranas por medio de un clic del mouse, haciendo un salto en el sentido respectivo de cada rana, que puede ser de un espacio o de dos espacios si es que hay una rana del color opuesto.
Existen 2 soluciones para este juego, esta se determina por elprimer movimiento que se realice, es decir, si la rana verde inicia la primer jugada corresponde a una solución y si se comienza con una rana marrón es otra solución, aunque se respeta el mismo patrón de movimientos, que se tiene que seguir rigurosamente para poder terminar, en caso de que se haga un movimiento fuera de este patrón, impediría que se pueda concluir este juego.

DESARROLLO
FASE1
OBJETIVO: Pasar las ranas verdes a las piedras de la derecha y las marrón a las piedras de la izquierda, siendo 7 piedras en total.
ENTRADA: Dar clic en la rana correcta para ir avanzando de posición.
SALIDA: Clic en una rana verde = salto a la derecha, clic en rana marrón = salto a la izquierda.
PROCESO: PSEUDOCODIGO
1.
2. INICIO
3. Declaración de variables
(ranver1, 2, 3y ranmar1, 2, 3)
4. Leer clic
5. Si clic = ranver1 entonces
6. Ranver1 salta a piedra 4
7. Leer clic
8. Si clic = ranmar1 entonces
9. Ranmar1 salta a piedra3
10. Fin si
11. Leer clic
12. Si clic = ranmar2 entonces
13. Ranmar2 salta a pidera5
14. Si no
15. Ranver1 salta apiedra5
16. Mostrar “Reiniciar”
17. Regresar a paso 3
18. Fin si
19. Leer clic
20. Si clic = ranver1 entonces
21. Ranver1 salta a piedra6
22. Sino
23. Ranmar3 salta a piedra 6
24. “Mostrar reiniciar”
25. Regresar a paso 3
26.Fin si
27. Leer clic
28. Si clic = ranver2 entonces
29. Ranver2 salta a pidera4
30. Si no
31. Ranmar2 salta a piedra4
32. Mostrar “Reiniciar”
33. Regresar a paso 3
34. Fin si
35. Leer clic
36. Si clic = ranver3 entonces
37. Ranver3 salta apidera2
38. Si no
39. Ranmar1 salta a piedra2
40. Mostrar “Reiniciar”
41. Regresar a paso 3
42. Fin si
43. Leer clic
44. Si clic = ranmar1 entonces
45. Ranmar1 salta a pidera1
46. Fin si
47. Si clic = ranmar2 entonces
48. Ranmar2 salta a pidera349. Si no
50. Ranver3 salta a piedra3
51. Mostrar “Reiniciar”
52. Regresar a paso 3
53. Fin si
54. Leer clic
55. Si clic = ranmar3 entonces
56. Ranmar3 salta a pidera5
57. Si no
58. Ranver2 salta a piedra5
59. Mostrar “Reiniciar”...
tracking img