Diagramas de flujo del profesor gastaldi fes aragon

Solo disponible en BuenasTareas
  • Páginas : 5 (1011 palabras )
  • Descarga(s) : 0
  • Publicado : 15 de marzo de 2011
Leer documento completo
Vista previa del texto
7.-Suma de Matrices
Inicio

M,m1,n,n1


I=1, m1 , 1

j=1, n1 , 1


aij




bij
j=1, n2 , 1
I=1, m2 , 1


j=1, n2 , 1
I=1, m1 , 1

Cij=aij+bij

cij
bij
aij
j=1, n1 , 1
I=1, m1 , 1
j=1, n1 , 1
I=1, m1 , 1
j=1, n1 , 1
I=1, m1 , 1

Fin



inicio
librerías
enteros m,n,i,j
reales a[10][10],b[10][10],c[10][10]
imprime programa que sumamatrices
imprime cuantos renglones quieres?
leer m
imprime cuantos columnas quieres ?
leer n
para i=1, m, 1
para j=1, n, 1
imprime dame a[i][j]
leer a[i][j]
fin para
fin para
para i=1, m, 1
para j=1, n, 1
imprime dame b[i][j]
leer b[i][j]
fin para
fin para
para i=1, m, 1
para j=1, n, 1
c[i][j]=a[i][j]+b[i][j]
fin para
fin para
para i=1, m, 1
imprimesalto de línea
para j=1, n, 1
imprime a[i][j]
fin para
fin para
para i=1, m, 1
imprime salto de línea
para j=1, n, 1
imprime b[i][j]
fin para
fin para
para i=1, m, 1
imprime salto de línea
para j=1, n, 1
imprime c[i][j]
fin para
fin para
Fin







8.-Multiplicacion de Matrices
Inicio

M,m1,n,n1


I=1, m1 , 1

j=1, n1 , 1


aijbij
j=1, n2 , 1
I=1, m2 , 1


Cij=(aik)(bkj)+cij
K=1, n1, 1
j=1, n2 , 1
I=1, m1 , 1

cij
bij
aij
j=1, n1 , 1
I=1, m1 , 1
j=1, n1 , 1
I=1, m1 , 1
j=1, n1 , 1
I=1, m1 , 1

Fin

inicio
librerías
enteros m1,m2,n1,n2,i,j,k
reales a[10][10],b[10][10],c[10][10]
imprime programa que multiplica matrices
imprime cuantos renglones quieres?
leer m1
imprimecuantas columnas quieres ?
leer n1
imprime cuantas columnas quieres?
leer m2
n1=m1
para i=1, m1, 1
para j=1, n1, 1
imprime dame a[i][j]
leer a[i][j]
fin para
fin para
para i=1, m2, 1
para j=1, n2, 1
imprime dame b[i][j]
leer b[i][j]
fin para
fin para
para i=1, m1, 1
para j=1, n2, 1
para k=1, n1, 1
c[i][j]=(a[i][k]*b[k][j])+c[i][j]
fin para
fin para
parai=1, m, 1
imprime salto de línea
para j=1, n, 1
imprime a[i][j]
fin para
fin para
para i=1, m, 1
imprime salto de línea
para j=1, n, 1
imprime b[i][j]
fin para
fin para
para i=1, m1, 1
imprime salto de línea
para j=1, n2, 1
imprime c[i][j]
fin para
fin para
Fin

9.-Convertir un Numero a Binario
f=fx2
j=1, n1 , 1
e=c
c=e/2
ri=e-2c
i=i+1
e!=0
i=0
f=d-ee=d
d
Inicio

f=>1.0

bj=1
f=f-1
bj=0


bi
i=1, 8 , 1
.
rk
k=i, 1 , -1

FIN


inicio
librerías
enteros e, i, c, j, r[20], b[8], k
reales d, f, n
imprime programa que convierte un números decimal a binario
imprime dame el numero
leer n
e=n
d=n-e
i=o
mientras e no sea igual a 0
e=e/2
i=i+1
r[i]=e-(2c)
e=c
para j=1, 8, 1
d=d*2
si d>=1.0d=d-1
b[j]=1
en caso contrario
b[j]=0
imprime En Numero en Binario es:
para k=i. 1, -1
imprime r[k]
fin para
imprime “.”
Para i=1, 8, 1
Imprime b[i]
Fin para
Fin











10.-Menu (Switch) Calculator 300
FIN
m==si
c
Error
c=a-b

c=a/b

c=a*b

c=a+b
opcion
a,b
INICIO




Inicio
Librerías
Imprime programa calculator3000
Haslo mientras
{
Imprime dame el primer valor
Leer a
Imprime dame el segundo valor
Leer b
Imprime 1.-sumar los números
Imprime 2.-Multiplicar los numero
Imprime 3.-dividir los números
Imprime 4.-Restar los números
Leer opción
Caso 1
c=a+b
termina caso
caso 2
c=a*b
termina caso
caso 3
c=a/b
termina caso
caso 4
c=a-b
termina caso
caso defaultimprime la opción es incorrecta
termina caso
mientras sea si
repite todo
}
Fin


11.-Promedio de 5 Materias Validando Califinaciones
Inicio

x<0
x>10
x

si no

x=0
b
x<0
x
x>10
a
si no





x
x=0
d
x<0
x
x>10
x=0
c
x<0
x
x>10
x=0




e
x<0
x>10

Fin
r
r =(a+b+c+d+e)/5


Inicio
Librerías...
tracking img